Bug 1012814 - all openstack services: unable to connect to AMQP server (after upgrading to qpid 0.24)
all openstack services: unable to connect to AMQP server (after upgrading to ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Francesco Vollero
Fedora Extras Quality Assurance
: Reopened
Depends On: 1012001
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 04:05 EDT by Martin Magr
Modified: 2015-04-29 03:29 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.12.dev835.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1012001
Environment:
Last Closed: 2015-04-29 03:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 52135 None None None Never

  None (edit)
Description Martin Magr 2013-09-27 04:05:17 EDT
+++ This bug was initially created as a clone of Bug #1012001 +++

Description of problem:
it seems, 
https://admin.fedoraproject.org/updates/FEDORA-2013-17562/qpid-cpp-0.24-2.fc19
landed in Fedora 19.

It now places qpidd.conf under /etc/qpid/qpidd.conf instead of directly in /etc.
Qpid places it's qpidd.conf directly in /etc.

This results in qpid expecting authentication.

--- Additional comment from Darryl L. Pierce on 2013-09-25 11:34:53 EDT ---

This is where the Qpid configuration files will live going forward, in /etc/qpid.

--- Additional comment from Pádraig Brady on 2013-09-25 16:23:38 EDT ---

Darryl, there is a compatibility cost of course with moving configs around.
Have you considered that and a possible transition period/process to support for example /etc/qpidd.conf as a symlink into /etc/qpid/ or something?

--- Additional comment from Darryl L. Pierce on 2013-09-25 16:48:25 EDT ---

(In reply to Pádraig Brady from comment #2)
> Darryl, there is a compatibility cost of course with moving configs around.
> Have you considered that and a possible transition period/process to support
> for example /etc/qpidd.conf as a symlink into /etc/qpid/ or something?

No, that wasn't considered. Having a symlink from /etc/qpid/qpidd.conf to /etc/qpidd.conf wouldn't work since qpidd will look for the configuration in /etc/qpidd.

I discussed this with other package maintainers. The general consensus was that, since the upgrade process would leave the file /etc/qpidd.conf.rpmsave behind after an upgrade, along with the release notes for the server, the sysadmin would take the appropriate steps to migrate their existing configuration to the new file location.

--- Additional comment from Pádraig Brady on 2013-09-25 20:41:45 EDT ---

(In reply to Darryl L. Pierce from comment #3)
> (In reply to Pádraig Brady from comment #2)
> > Darryl, there is a compatibility cost of course with moving configs around.
> > Have you considered that and a possible transition period/process to support
> > for example /etc/qpidd.conf as a symlink into /etc/qpid/ or something?
> 
> No, that wasn't considered. Having a symlink from /etc/qpid/qpidd.conf to
> /etc/qpidd.conf wouldn't work since qpidd will look for the configuration in
> /etc/qpidd.

What I mean here is that qpid could use the new /etc/qpid/qpidd.conf
while other tools like puppet modules etc. could continue to use
/etc/qpidd.conf (symlink) until updated to the new location.

> I discussed this with other package maintainers. The general consensus was
> that, since the upgrade process would leave the file /etc/qpidd.conf.rpmsave
> behind after an upgrade, along with the release notes for the server, the
> sysadmin would take the appropriate steps to migrate their existing
> configuration to the new file location.

I don't think this is acceptable during a release TBH.
I.E. the system shouldn't break on (auto) update.

--- Additional comment from Matthias Runge on 2013-09-26 04:10:09 EDT ---

IMHO this fits here: http://fedoraproject.org/wiki/Updates_Policy#All_other_updates

I even disagree with the request to support both config options (/etc/qpidd.conf) and /etc/qpid/qpidd.conf), because qpid brings it's new, own config to /etc/qpid/qpidd.conf). Given some script like puppet places a new qpid.conf in /etc, which config should have precedence? I see arguments in both directions. 
So this upgrade in a released version is currently more than just unfortunate.

--- Additional comment from Darryl L. Pierce on 2013-09-26 08:20:32 EDT ---

(In reply to Matthias Runge from comment #5)
> IMHO this fits here:
> http://fedoraproject.org/wiki/Updates_Policy#All_other_updates
> 
> I even disagree with the request to support both config options
> (/etc/qpidd.conf) and /etc/qpid/qpidd.conf), because qpid brings it's new,
> own config to /etc/qpid/qpidd.conf). Given some script like puppet places a
> new qpid.conf in /etc, which config should have precedence? I see arguments
> in both directions. 
> So this upgrade in a released version is currently more than just
> unfortunate.

I'm willing, for the 0.24 release, to modify the spec to create a symlink from /etc/qpid/qpidd.conf to /etc/qpid.conf if that will smooth the transition. However, anybody who has modified their configuration will still need to migrate their configuration to the new file. Will that provide a sufficient transition?

--- Additional comment from Fedora Update System on 2013-09-26 16:29:46 EDT ---

qpid-cpp-0.24-4.fc20.1 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/qpid-cpp-0.24-4.fc20.1

--- Additional comment from Fedora Update System on 2013-09-26 16:51:40 EDT ---

qpid-cpp-0.24-3.fc19.1 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qpid-cpp-0.24-3.fc19.1

--- Additional comment from Fedora Update System on 2013-09-26 17:11:15 EDT ---

qpid-cpp-0.24-3.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.24-3.fc18.1

--- Additional comment from Martin Magr on 2013-09-27 04:03:53 EDT ---

This won't help in case of puppet-qpid module, but I guess we would have to fix that in the module.
Comment 1 Fedora Admin XMLRPC Client 2013-10-14 05:50:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2013-10-14 05:51:16 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.