Bug 1012818 - Fail to list the domjobinfo while migrate the guest with the --compressed option
Fail to list the domjobinfo while migrate the guest with the --compressed option
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 04:21 EDT by zhenfeng wang
Modified: 2014-06-17 20:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-8.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhenfeng wang 2013-09-27 04:21:54 EDT
Description of problem:
Fail to list the domjobinfo while migrate the guest with the --compressed option

Version-Release number of selected component (if applicable):
qemu-kvm-1.5.3-7.el7.x86_64
kernel-3.10.0-28.el7.x86_64
libvirt-1.1.1-7.el7.x86_64

How reproducible:
100%

Steps
1. set setenforce 1 && virt_use_nfs 1 (on both source and target)

2.prepare a guest which the image file is on the NFS server,and mount the nfs server on both source and target
start the guest on the source machine
#virsh start rhelguest1
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 8     rhel7raw                         running

3.Migrate the guest and check the domjobinfo in another terminal at the same time
# virsh migrate --live rhel7raw qemu+ssh://xx.xx.xx.xx/system --verbose --compressed 
The authenticity of host 'xx.xx.xx.xx (xx.xx.xx.xx)' can't be established.
RSA key fingerprint is 48:bb:3c:6d:85:2d:bcf:1a:4c:11:a8:19:66:f2:ee.
Are you sure you want to continue connecting (yes/no)? yes
root@10.66.83.172's password:
Migration: [40 %]


check the domjob info
# virsh domjobinfo rhel7raw
error: Too many job stats '19' for limit '16'
error: Reconnected to the hypervisor        


Actual results:
It report error while check the domjobinfo during the migration
Expected results:
Should list the domjobinfo correctly
Comment 1 Jiri Denemark 2013-09-27 07:04:21 EDT
Fixed upstream by v1.1.3-rc1-9-gf25a087:

commit f25a08747de3589605f7f288cec61e0c182fbb7f
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Fri Sep 27 10:48:02 2013 +0200

    rpc: Increase bound limit for virDomainGetJobStats
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1012818
    
    Commit 6d7d0b1869ed293e3208d11f375cecea0129dfc5 (in 1.1.2) added bounds
    checking to virDomainGetJobStats. But even at that time the API was able
    to return 20 parameters while the limit was set to 16.
    
    Signed-off-by: Jiri Denemark <jdenemar@redhat.com>
Comment 4 zhenfeng wang 2013-10-09 05:19:09 EDT
Verify this bug with the libvirt-1.1.1-8.el7, the following was the verify steps
1. set setenforce 1 && virt_use_nfs 1 (on both source and target)

2.prepare a guest which the image file is on the NFS server,and mount the nfs server on both source and target
start the guest on the source machine
#virsh start rhelguest1
# virsh list --all
 Id    Name                           State
----------------------------------------------------
 8     rhel7raw                         running

3.Migrate the guest and check the domjobinfo in another terminal at the same time
# virsh migrate --live rhel7raw qemu+ssh://xx.xx.xx.xx/system --verbose --compressed 
The authenticity of host 'xx.xx.xx.xx (xx.xx.xx.xx)' can't be established.
RSA key fingerprint is 48:bb:3c:6d:85:2d:bcf:1a:4c:11:a8:19:66:f2:ee.
Are you sure you want to continue connecting (yes/no)? yes
root@10.66.83.172's password:
Migration: [40 %]


check the domjob info
# virsh domjobinfo rhel7raw
Job type:         Unbounded   
Time elapsed:     2902         ms
Data processed:   267.817 MiB
Data remaining:   116.016 MiB
Data total:       1.125 GiB
Memory processed: 267.817 MiB
Memory remaining: 116.016 MiB
Memory total:     1.125 GiB
Constant pages:   197140      
Normal pages:     68185       
Normal data:      266.348 MiB
Expected downtime: 30           ms
Compression cache: 64.000 MiB
Compressed data:  0.000 B
Compressed pages: 0            
Compression cache misses: 0            
Compression overflows: 0       

Since the domjobinfo was listed correctly while do the migration, so mark this bug verified
Comment 5 Ludek Smid 2014-06-13 07:35:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.