Bug 1012873 - static test should check provides static not requires
static test should check provides static not requires
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 06:03 EDT by Jens Petersen
Modified: 2014-01-07 04:40 EST (History)
3 users (show)

See Also:
Fixed In Version: fedora-review-0.5.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 05:37:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this trival untested patch should hopefully fix the problem (608 bytes, patch)
2013-09-27 06:03 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Jens Petersen 2013-09-27 06:03:51 EDT
Created attachment 803856 [details]
this trival untested patch should hopefully fix the problem

Description of problem:
fedora-review checks for static libraries in devel packages, etc.
If the devel package with *.a provides %{name}-static then it
should be okay.  However fedora-review seems to be do this
incorrectly - it is checks the devel package requires for
%{name}-static not the provides.

Version-Release number of selected component (if applicable):
0.5.0

How reproducible:
100%

Steps to Reproduce:
1. run fedora-review on Haskell library package review with provides for static
   (Haskell libraries include static libs in -devel)

Actual results:
1. fedora-review still complains about -devel not providing -static.

Expected results:
1. warning to be skipped when provides there

Additional info:
Comment 1 Jens Petersen 2013-11-18 00:28:18 EST
Ping :)

Anything I can do to help get this included?
Comment 2 Alec Leamas 2013-11-20 10:55:35 EST
I pushed a tentative fix to devel: http://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=c7eef8b . Could you do some testing on current devel branch?
Comment 3 Jens Petersen 2013-11-21 05:33:28 EST
Thanks!  I tested git devel e2d22d8 and yes it seems to fix this problem.
Comment 4 Alec Leamas 2013-11-21 05:37:34 EST
Thanks for spotting this! As you noted, it was a trivial copy-paste error which have slipped through reviews and testing.
Comment 5 Fedora Update System 2013-12-13 09:59:20 EST
fedora-review-0.5.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.fc18
Comment 6 Fedora Update System 2013-12-13 09:59:58 EST
fedora-review-0.5.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.el6
Comment 7 Fedora Update System 2013-12-13 10:01:15 EST
fedora-review-0.5.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.fc19
Comment 8 Fedora Update System 2013-12-19 02:05:58 EST
fedora-review-0.5.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-06 20:20:37 EST
fedora-review-0.5.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2014-01-07 04:35:59 EST
fedora-review-0.5.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-01-07 04:40:54 EST
fedora-review-0.5.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.