This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012881 - [RFE] Allow filling also network prefix to 'netmask' fields of static IP configuration
[RFE] Allow filling also network prefix to 'netmask' fields of static IP conf...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity low
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Dan Kenigsberg
Meni Yakove
: EasyFix, FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 06:17 EDT by David Jaša
Modified: 2016-03-09 15:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
This release adds prefix format support. Both netmask and prefix format are now supported in the netmask field of static IP configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 15:33:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nyechiel: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 35144 master MERGED common: adding maskValidator util Never
oVirt gerrit 35145 master MERGED webadmin: allowing prefix as mask staticIP conf Never
oVirt gerrit 35155 master MERGED backend: adding @Mask annotation Never
oVirt gerrit 35410 master MERGED backend: integrate @mask to VdsNetworkInterface Never
oVirt gerrit 36529 master MERGED backend: allowing mask as prefix Never

  None (edit)
Description David Jaša 2013-09-27 06:17:10 EDT
Description of problem:
Using netmasks is cumbersome: they're much longer and harder to remember as opposed to corresponding network prefix. The correct prefix can not be interchanged with correct netmask, conversion is quite straightforward and newer low-level tools work with prefixes natively.
Therefore I propose the "Netmask" fields (and appropriate places in API) to have their heading changed to "Netmask/Prefix" and have them accept integers in 0-32 range as correct prefix values.

This is IMO quite a small change nice leap forward in convenience in environments with statically assigned IP configuration.

Version-Release number of selected component (if applicable):
RHEV 3.3.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Nir Yechiel 2014-11-13 13:14:18 EST
Hi Eliraz,

I have a question with regards to the implementation of this; currently there is a netmask field in which the user should enter the subnet mask in dot-decimal notation (x.x.x.x). With this change, are we going to change that and only accept CIDR notation (/xx)? Or the user can fill the info in either way (dot-decimal or CIDR)?

Thanks,
Nir
Comment 4 Lior Vernia 2014-11-16 04:22:01 EST
The current design is to accept either, but always report in dot-decimal format.
Comment 5 Michael Burman 2015-04-28 04:49:59 EDT
Verified on - 3.6.0-0.0.master.20150412172306.git55ba764.el6
with vdsm-4.17.0-632.git19a83a2.el7.x86_64
Comment 8 errata-xmlrpc 2016-03-09 15:33:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html

Note You need to log in before you can comment on or make changes to this bug.