This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1012885 - horizon: getting a bad request page when trying to create a swift container with % in the name
horizon: getting a bad request page when trying to create a swift container w...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
x86_64 Linux
unspecified Severity medium
: Upstream M1
: 5.0 (RHEL 7)
Assigned To: Julie Pichon
Amit Ugol
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 06:23 EDT by Dafna Ron
Modified: 2015-02-15 17:02 EST (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1-4.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, when a container was named with '%' character, the URL in the Dashboard would break, causing a 'Bad Request' page to be returned. As a result, Horizon would fail to create containers with the name containing '%' character. It would also fail to list, upload or download files from such a container. With this bug fix, the URLs are quoted properly. Users can now create containers with '%' in the name using the Dashboard and also list, upload and downloads files from such a container.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-08 11:42:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (5.66 KB, application/x-gzip)
2013-09-27 06:23 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1231904 None None None Never
OpenStack gerrit 55702 None None None Never

  None (edit)
Description Dafna Ron 2013-09-27 06:23:57 EDT
Created attachment 803872 [details]
logs

Description of problem:

I was testing special characters container requests and if you create a container with % in the name we get a bad request page: 

Bad Request

Your browser sent a request that this server could not understand.
Apache/2.2.15 (Red Hat) Server at nott-vdsa.qa.lab.tlv.redhat.com Port 80

also, for some cases the container will be created but we cannot list/upload or download files from it. 

testing the swift UI it can support it as long as we put '***' so please note that even if horizon blocks special characters we can still create them from swift. 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.2-0.12b3.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. try to create a container called b%b
2.
3.

Actual results:

we get a bad request page from horizon 

Expected results:

requests for special characters should be sent with 'b%b' since swift does support this and a user can still create a container from the cli and than not be able to list it from horizon. 


Additional info:
Comment 2 Julie Pichon 2014-01-21 11:18:57 EST
Fixed in Icehouse-1 upstream (commit 5a57c1ee704).
Comment 3 Julie Pichon 2014-05-27 05:56:16 EDT
As per previous comment, this was merged during Icehouse upstream and should already be available in the existing RHEL OSP 5 packages.
Comment 4 Amit Ugol 2014-06-18 04:52:42 EDT
Verified, I tried %, along with some other esoteric charecters.
Comment 6 errata-xmlrpc 2014-07-08 11:42:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html

Note You need to log in before you can comment on or make changes to this bug.