Bug 1012889 - Unplug external monitor, laptop no longer suspends on lid close
Unplug external monitor, laptop no longer suspends on lid close
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-desktop (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 06:34 EDT by Colin Macdonald
Modified: 2014-05-20 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-20 09:39:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Macdonald 2013-09-27 06:34:22 EDT
Description of problem:
Normally a lid close suspends my laptop.  After a external VGA monitor is connected, lid close no longer suspends machine---even after external monitor disconnected.

How reproducible:
Depends on how long I wait, but I think everytime I disconnect and then suspend.


Steps to Reproduce:
1.  close lid, note laptop suspends.  Then open.
2.  attach VGA monitor (other's not tested).
3.  unplug VGA, wait a few seconds
4.  close lid, *laptop does not suspend.*
5.  manually suspend (keyboard or menu)
6.  open machine, now close again and suspend works normally.

Note "wait a few seconds": if you leave it for say 5mins after disconnect, it works correctly.  If I get around to determining how long, I'll add that info.

Will test again with F20 once I upgrade.
Comment 1 Colin Macdonald 2014-01-16 19:33:06 EST
Still present on F20.  If I wait approx 30 seconds, it works correctly.

Also present with DP and HDMI outputs.
Comment 2 Colin Macdonald 2014-05-20 09:39:26 EDT
Sounds like this is intended behaviour, #1081093, possibly with some bugs #1092905.

But the 30 second thing is deliberate.

Note You need to log in before you can comment on or make changes to this bug.