Bug 1012933 - Stream mode with CR4-Pre1 generates rules looping
Summary: Stream mode with CR4-Pre1 generates rules looping
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: BRE
Version: 6.0.0
Hardware: All
OS: All
urgent
urgent
Target Milestone: ER5
: 6.0.0
Assignee: Mario Fusco
QA Contact: Tomas David
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-27 12:05 UTC by Richard Bourner
Modified: 2014-08-06 20:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:17:41 UTC
Type: Bug


Attachments (Terms of Use)
Maven Eclipse project demonstrating the issue (29.57 KB, application/x-zip-compressed)
2013-09-27 12:05 UTC, Richard Bourner
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker DROOLS-276 0 Blocker Resolved Stream mode with CR4-Pre1 generates rules looping 2013-12-13 15:45:38 UTC

Description Richard Bourner 2013-09-27 12:05:01 UTC
Created attachment 803925 [details]
Maven Eclipse project demonstrating the issue

Description of problem:
When in STREAM mode our rules are looping because of an update.
The attached example doesn't demonstrate the looping but one rule is fired twice where it should only fire once. We are supposing that the issue is the same.

Version-Release number of selected component (if applicable):
Drools 6.0.0.CR4-Pre1

How reproducible:
Run the unit test in the attached Maven Eclipse project.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 JBoss JIRA Server 2013-10-03 12:37:10 UTC
Richard Bourner <richard@bourner.fr> made a comment on jira DROOLS-276

A little precision: it appears that the problem occurs only with Phreak algo in Stream mode.
In the unit test I created, I had not included the reteoo JAR, so it was redirected to Phreak without my noticing.
Bottom line: out of 4 unit tests, only 1 fails now.

Comment 3 Richard Bourner 2013-10-03 12:38:13 UTC
A little precision: it appears that the problem occurs only with Phreak algo in Stream mode.
In the unit tests I created, I had not included the reteoo JAR, so it was redirected to Phreak without my noticing.
Bottom line: out of 4 unit tests, only 1 fails now.

Comment 4 Mario Fusco 2013-10-04 13:37:14 UTC
Fixed by https://github.com/droolsjbpm/drools/commit/14387151e

Comment 5 JBoss JIRA Server 2013-10-04 13:38:01 UTC
Mario Fusco <mario.fusco@gmail.com> updated the status of jira DROOLS-276 to Resolved

Comment 6 Tomas David 2013-12-11 16:37:37 UTC
Verified on BRMS 6.0.0.ER5.


Note You need to log in before you can comment on or make changes to this bug.