Bug 1012934 - spacewalk-archive-audits fails with ORA-00911 error on Oracle backend
spacewalk-archive-audits fails with ORA-00911 error on Oracle backend
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Grant Gainey
Jiří Mikulka
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-09-27 08:11 EDT by Jiří Mikulka
Modified: 2014-10-06 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-utils-2.0.2-12-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:52:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-09-27 08:11:49 EDT
Description of problem:
spacewalk-archive-audits fails with traceback on Satellite 5.6 with Oracle backend due to ORA-00911 error.

Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL5-re20130926.0
spacewalk-utils-2.0.2-11.el5sat.noarch

How reproducible:
always

Steps to Reproduce:
1. run spacewalk-archive-audits --list
2. check the output

Actual results:

# spacewalk-archive-audits --list
Traceback (most recent call last):
  File "/usr/bin/spacewalk-archive-audits", line 209, in ?
    list(options)
  File "/usr/bin/spacewalk-archive-audits", line 156, in list
    names = tables()
  File "/usr/bin/spacewalk-archive-audits", line 131, in tables
    stmt = rhnSQL.execute(_get_sql('FIND_TABLE'))
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/__init__.py", line 172, in execute
    return apply(db.execute, (sql, ) + args, kwargs)
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 490, in execute
    apply(cursor.execute, args, kwargs)
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 163, in execute
    return apply(self._execute_wrapper, (self._execute, ) + p, kw)
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 108, in _execute_wrapper
    retval = apply(function, p, kw)
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/sql_base.py", line 217, in _execute
    return self._execute_(args, kwargs)
  File "/usr/lib/python2.4/site-packages/spacewalk/server/rhnSQL/driver_cx_Oracle.py", line 161, in _execute_
    self._real_cursor.execute(*(None, ), **params)
spacewalk.server.rhnSQL.sql_base.SQLStatementPrepareError: ('ORA-00911: invalid character\n', 911, "select table_name from user_tables where table_name like '%!_LOG' escape '!';")

Expected results:
# spacewalk-archive-audits --list
                 web_contact_log : 8
                   rhnserver_log : 3600
              rhnservergroup_log : 3076

Additional info:
this is only Oracle issue
Comment 1 Jan Hutař 2013-09-27 09:13:23 EDT
*** Bug 1012963 has been marked as a duplicate of this bug. ***
Comment 2 Grant Gainey 2013-09-27 09:53:14 EDT
SW 0c9cef2175ec68af148fef2257b62489320c605e spacewalk-utils-2.1.18-1
Comment 6 Clifford Perry 2013-10-01 17:52:02 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.