Bug 1012937 - [virtio-win][netkvm][wlk]BSOD 7E happened during job "Ethernet-NEISTest6.0" in win2k8-64 with build 71 driver.
[virtio-win][netkvm][wlk]BSOD 7E happened during job "Ethernet-NEISTest6.0" i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 08:18 EDT by guo jiang
Modified: 2014-01-01 11:32 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:32:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guo jiang 2013-09-27 08:18:09 EDT
Description of problem:
BSOD 7E happened during job "Ethernet-NEISTest6.0" in win2k8-64 with build 71 driver. 

Version-Release number of selected component (if applicable):
  Red Hat Enterprise Linux Server release 6.4 (Santiago)
  kernel-2.6.32-420.el6.x86_64    
  qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
  virtio-win-prewhql-0.1-71
  spice-server-0.12.4-3.el6.x86_64
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch

How reproducible:
3/3

Steps to Reproduce:
1.boot guest with CLI:
 /usr/libexec/qemu-kvm \
-M rhel6.5.0 \
-m 6G \
-smp 8,cores=8 \
-cpu cpu64-rhel6 \
-usb \
-device usb-tablet \
-drive file=win2k8-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 \
-netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no \
-device virtio-net-pci,netdev=hostnet0,mac=00:43:22:12:23:42,bus=pci.0,addr=0x4,id=virtio-net-pci0,ctrl_guest_offloads=on \
-netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no \
-device virtio-net-pci,netdev=hostnet1,mac=00:32:32:32:23:32,bus=pci.0,addr=0x5,id=virtio-net-pci1,ctrl_guest_offloads=on \
-netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no \
-device e1000,netdev=hostnet2,mac=00:23:33:11:a4:21,bus=pci.0,addr=0x6 \
-uuid 91f5022b-ee47-4048-8895-46871029774c \
-no-kvm-pit-reinjection \
-chardev socket,id=111a,path=/tmp/monitor-win2k8-64-71-nic1,server,nowait \
-mon chardev=111a,mode=readline \
-vnc :1 \
-vga cirrus \
-name win2k8-64-nic1-71-WLK \
-rtc base=localtime,clock=host,driftfix=slew \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-monitor stdio

2.run "Ethernet-NEISTest6.0".

3.run "Start NDISTest Client&Start NDISTest Server" task

Actual results:
Guest BOSD with 7E

Expected results:
Job could pass without any error.

Additional info:
Comment 1 guo jiang 2013-09-27 08:19:13 EDT
Windbg info:
Use !analyze -v to get detailed debugging information.

BugCheck 7E, {ffffffff80000003, fffffa600647e7cb, fffffa600545da38, fffffa600545d410}

*** ERROR: Module load completed but symbols could not be loaded for NDProt60.sys
Probably caused by : NDProt60.sys ( NDProt60+747cb )

Followup: MachineOwner
---------

3: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (7e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arguments:
Arg1: ffffffff80000003, The exception code that was not handled
Arg2: fffffa600647e7cb, The address that the exception occurred at
Arg3: fffffa600545da38, Exception Record Address
Arg4: fffffa600545d410, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid

FAULTING_IP: 
NDProt60+747cb
fffffa60`0647e7cb cc              int     3

EXCEPTION_RECORD:  fffffa600545da38 -- (.exr 0xfffffa600545da38)
ExceptionAddress: fffffa600647e7cb (NDProt60+0x00000000000747cb)
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 1
   Parameter[0]: 0000000000000000

CONTEXT:  fffffa600545d410 -- (.cxr 0xfffffa600545d410)
rax=fffffa800706c5d0 rbx=0000000000000000 rcx=0000000000000001
rdx=0000000000000000 rsi=fffffa8006fb3c58 rdi=fffffa8004f57040
rip=fffffa600647e7cb rsp=fffffa600545dc70 rbp=0000000000000080
 r8=ffffffffffffffff  r9=8101010101010100 r10=810101010100e0e0
r11=fffffa800700c030 r12=fffffa6006492470 r13=0000000000000000
r14=fffffa8004f57040 r15=fffffa60017dbcc0
iopl=0         nv up ei ng nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00000282
NDProt60+0x747cb:
fffffa60`0647e7cb cc              int     3
Resetting default scope

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x7E

PROCESS_NAME:  System

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_PARAMETER1:  0000000000000000

LAST_CONTROL_TRANSFER:  from fffffa60064924c3 to fffffa600647e7cb

STACK_TEXT:  
fffffa60`0545dc70 fffffa60`064924c3 : fffffa80`06fb3c28 00000000`00000000 00000000`00000000 00000000`00000000 : NDProt60+0x747cb
fffffa60`0545dd00 fffff800`018b6227 : fffffa80`06fb3c58 00000000`00000000 00000000`00000000 00000000`00000001 : NDProt60+0x884c3
fffffa60`0545dd50 fffff800`016e7456 : fffffa60`017d8180 fffffa80`0784bbb0 fffffa60`017e1d40 fffffa60`017d87f0 : nt!PspSystemThreadStartup+0x57
fffffa60`0545dd80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16


FOLLOWUP_IP: 
NDProt60+747cb
fffffa60`0647e7cb cc              int     3

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  NDProt60+747cb

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: NDProt60

IMAGE_NAME:  NDProt60.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  4d4c09c8

STACK_COMMAND:  .cxr 0xfffffa600545d410 ; kb

FAILURE_BUCKET_ID:  X64_0x7E_VRF_NDProt60+747cb

BUCKET_ID:  X64_0x7E_VRF_NDProt60+747cb

Followup: MachineOwner
---------
Comment 4 Dmitry Fleytman 2013-09-27 11:34:24 EDT
Please provide WLK logs also.
Comment 5 Mike Cao 2013-10-08 06:27:33 EDT
we did not hit this issue on virtio-win-prewhql-71

Based on above ,move status to verified

Note You need to log in before you can comment on or make changes to this bug.