Bug 101295 - Compiler crashes with "please report bug" message.
Summary: Compiler crashes with "please report bug" message.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc3 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL: http://monk.webintl.com/bugs/bugs.txt
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 17:35 UTC by Michael King
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version: 3.2.3-13, 3.3-17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 14:23:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mframe.mi file requested (99.09 KB, text/plain)
2003-08-04 14:32 UTC, Michael King
no flags Details

Description Michael King 2003-07-30 17:35:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
As seen in the about URL, I'm attempting to compile the swarm kit
(www.swarm.org), but it's giving me a weird error I've never seen before..
Something that's apparently wrong with the compiler, not anything I'm compiling.

I'm stumped before I even began.

Version-Release number of selected component (if applicable):
gcc-3.2.2-5

How reproducible:
Always

Steps to Reproduce:
1. Download the latest source off of swarm.org, not the CVS
2. Configure
3. Make
    

Actual Results:  Error, as stated above.

Expected Results:  It should have compiled happily.

Additional info:

Comment 1 Jakub Jelinek 2003-08-04 07:03:08 UTC
If it is reproduceable, please attach mframe.mi (if you add -save-temps
option to the GCC command line which caused the internal compiler error,
it should create that file).

Comment 2 Michael King 2003-08-04 14:32:15 UTC
Created attachment 93371 [details]
mframe.mi file requested

I can still reproduce the problem, and here's the output mframe.mi..

Comment 3 Jakub Jelinek 2003-08-05 14:23:14 UTC
Cannot reproduce this in either gcc-3.2.3-13 or gcc-3.3-17.


Note You need to log in before you can comment on or make changes to this bug.