Bug 1012972 - Enter in 'Do you want to close the session?' dialog should be equal to hitting 'OK' button
Enter in 'Do you want to close the session?' dialog should be equal to hittin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Christophe Fergeau
Virtualization Bugs
:
Depends On:
Blocks: 1020669
  Show dependency treegraph
 
Reported: 2013-09-27 09:20 EDT by David Jaša
Modified: 2014-10-14 02:29 EDT (History)
11 users (show)

See Also:
Fixed In Version: virt-viewer-0.6.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1020669 (view as bug list)
Environment:
Last Closed: 2014-10-14 02:29:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-09-27 09:20:14 EDT
Description of problem:
Enter key in dialogs is usually equivalent of hitting OK button. This is not the case with virt-viewer where it toggles the widget with default focus - "Do not ask me again" checkbox. The default focus is correct IMO as it allows to toggle the checkbox with a single spacebar stroke but the Enter should work as usual, not to be redunant to spacebar.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.6-8
spice-gtk-0.20-9

How reproducible:
always

Steps to Reproduce:
1. connect with virt-viewer to some VM
2. File --> Exit
3. hit Enter

Actual results:
"Do not ask me again" is selected

Expected results:
virt-viewer exits

Additional info:
Comment 1 RHEL Product and Program Management 2013-10-13 21:54:01 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 tingting zheng 2013-10-18 01:44:52 EDT
I can reproduce this bug with virt-viewer-0.5.6-8.el6.x86_64.
Comment 4 Christophe Fergeau 2013-10-18 08:13:21 EDT
(with the caveat that this will activate Cancel by default, not Ok which I think is consistent with the intent of the dialog)
Comment 5 David Jaša 2013-10-18 11:49:37 EDT
(In reply to Christophe Fergeau from comment #4)
> (with the caveat that this will activate Cancel by default, not Ok which I
> think is consistent with the intent of the dialog)

That's not the right outcome. The default keyboard focus on checkbox is correct IMO, just the "Enter" key meaning should be changed to be "OK".
Comment 6 Christophe Fergeau 2013-10-18 11:59:13 EDT
The warning really means 'you are about to do something that may not be what you want, is it really ok?'
With such warnings, I think the right default action is to not carry on with what the user tries to do.
Comment 8 Cui Lei 2014-06-05 01:44:14 EDT
I can reproduce this issue with virt-viewer-0.5.6-8.el6.x86_64

Verify the issue with:
virt-viewer-0.6.0-4.el6

1. connect with virt-viewer to some VM
2. File --> Exit
3. hit Enter

Click 'Enter' key would activate Cancel, not enable 'Do not ask me again' before.

So change the status from 'ON_QA' to 'VERIFIED'.
Comment 9 errata-xmlrpc 2014-10-14 02:29:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html

Note You need to log in before you can comment on or make changes to this bug.