Bug 1012992 - grubby has moved /sbin/new-kernel-pkg to /usr/sbin/new-kernel-pkg
grubby has moved /sbin/new-kernel-pkg to /usr/sbin/new-kernel-pkg
Status: CLOSED DUPLICATE of bug 1008358
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grubby (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 10:24 EDT by Branislav Blaškovič
Modified: 2013-12-10 10:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 10:38:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Blaškovič 2013-09-27 10:24:44 EDT
Description of problem:
  I can not longer update my RHEL7, because of error:

Running transaction check
ERROR with transaction check vs depsolve:
/sbin/new-kernel-pkg is needed by (installed) kernel-3.10.0-0.rc7.64.el7.x86_64

The difference is, that grubby-8.28-2.el7.x86_64 contains /usr/sbin/new-kernel-pkg BUT pkg grubby-8.26-2.el7.x86_64 contains /sbin/new-kernel-pkg

I know, that /sbin is just symlink to /usr/sbin but maybe there are some problems with provides.

Please investigate it.

Version-Release number of selected component (if applicable):
  grubby-8.28-2.el7.x86_64.rpm
Comment 2 Radek Bíba 2013-09-30 09:07:12 EDT
You may want to move to this kernel bug:

Bug 1008358 - /sbin/new-kernel-pkg is needed by kernel-3.10.0-20.el7.x86_64

One of the comments also shows a snippet of grubby's changelog showing that what you're describing here is actually a fix for another bug.
Comment 3 David Cantrell 2013-12-10 10:38:20 EST

*** This bug has been marked as a duplicate of bug 1008358 ***

Note You need to log in before you can comment on or make changes to this bug.