Bug 1013020 - Pragha freezes when trying to a the bayern3 livestream
Pragha freezes when trying to a the bayern3 livestream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pragha (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
http://streams.br-online.de/bayern3_2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 11:31 EDT by Heiko Adams
Modified: 2014-04-05 22:36 EDT (History)
2 users (show)

See Also:
Fixed In Version: pragha-1.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 00:11:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2013-09-27 11:31:05 EDT
Description of problem:
When trying to add the livestream from Bayern3 Pragha freezes and doesn't react anymore until its getting killed.

Version-Release number of selected component (if applicable):
pragha-1.1.1-5.fc20.x86_64

How reproducible:
allways

Steps to Reproduce:
1. Start pragha
2. Add http://streams.br-online.de/bayern3_2.m3u as new location to the playlist
3.

Actual results:
Pragha freezes

Expected results:


Additional info:
Comment 1 Heiko Adams 2013-09-27 11:32:25 EDT
I forgot: This only happens with Bayern3 livestream. Other livestreams could be added without problems.
Comment 2 Christoph Wickert 2013-09-27 12:36:39 EDT
Connfirmed. --debug doesn't show anything.

Matias, any ideas other than strace?
Comment 3 Christoph Wickert 2013-09-27 14:45:35 EDT
Still exists in 1.1.2.1 from https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc20
Comment 4 mati86dl 2013-09-27 15:00:26 EDT
Hi,

Plese.. Test this patch: https://github.com/matiasdelellis/pragha/commit/7f9942dc68b335bdb2867f859a67aa29d3c223aa

If release a new version will be in a couple of weeks.. So please apply it in 1.1.2.1
Comment 5 Heiko Adams 2013-09-30 05:25:26 EDT
Seems to be fixed with todays libsoup update.
Comment 6 mati86dl 2013-10-09 20:13:02 EDT
I can not update libsoup. Anyone corroborate?

If it works, revert the commented commit.. This commit here works, but disables recursively playlists..
Comment 7 Fedora Update System 2014-02-14 18:25:22 EST
pragha-1.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pragha-1.2-1.fc20
Comment 8 Fedora Update System 2014-02-14 18:26:45 EST
pragha-1.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pragha-1.2-1.fc19
Comment 9 Fedora Update System 2014-02-15 15:03:09 EST
Package pragha-1.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pragha-1.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2608/pragha-1.2-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-03-11 00:11:53 EDT
pragha-1.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-04-05 22:36:05 EDT
pragha-1.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.