Bug 1013029 - Logs appear when completing a project
Logs appear when completing a project
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: Neus Miras
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 12:03 EDT by Michael
Modified: 2014-08-06 16:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Problem still present in ER4 (224.06 KB, text/x-log)
2013-10-21 01:01 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Michael 2013-09-27 12:03:47 EDT
Description of problem:

I created following project (with data model, process and forms): https://github.com/mbiarnes/examples.git
This project can be cloned into your application.
For the process execution are demanded two users. In my case michael and katy. You can see this in task_01 (michael), task_2.1(katy), task_03 (michael).
You should al least create two users.


Version-Release number of selected component (if applicable):
kie-wb-6.0.0.CR4-eap-6_1.war deployed in JBoss EAP 6.1.1

How reproducible:


Steps to Reproduce:
1. clone https://github.com/mbiarnes/examples.git into your project
2. build and deploy the project
3. start a process as user michael (or your user users)
you should see: https://gist.github.com/mbiarnes/6729723
4. got to task list and fill the form and complete the task
5. log out and log in as user katy (or your user)
6. go to task list and execute the task
now you should see in the logs. https://gist.github.com/mbiarnes/6729813
7. log out and log in as user michael and complete the process
8. start a new instance

Actual results:
you can complete the process and everything works properly. There are only these logs (https://gist.github.com/mbiarnes/6729723 and https://gist.github.com/mbiarnes/6729813).
This only seems to happen inthe first cicle of a process. If you have completed the first process instance the logs don'y appear.
Comment 2 Kris Verlaenen 2013-09-30 20:46:40 EDT
Michael, I couldn't reproduce the first issue.  It does appear that the form modeler generates the second error in the server log, but it doesn't appear to break anything.
Comment 3 Neus Miras 2013-10-02 11:14:12 EDT
Is a controlled situation, the log that was shown, has been passed to debug level.

Commits:

Master
https://github.com/droolsjbpm/jbpm-form-modeler/commit/8817180b20d4ae21ba1abfa91a709566fbf4b850

6.0.x
https://github.com/droolsjbpm/jbpm-form-modeler/commit/e0fffbf47ab70fcd88bd9e4aa75a48f0552d5460
Comment 4 Jan Hrcek 2013-10-21 01:00:42 EDT
I tried to reproduce the problem with BPMS 6.0.0 ER4 deployed on EAP 6.1.0 and I also didn't get the first error, but I got the second error. From the error message 'Error modifying formStatus:' it is clear, that Neus's commit that changed the log level to debug didn't get to ER4 build. I'll verify this issue with the next release - when the fix is included in ER5.

Attaching server.log - problem still present in ER4
Comment 5 Jan Hrcek 2013-10-21 01:01:18 EDT
Created attachment 814395 [details]
Problem still present in ER4
Comment 6 Jan Hrcek 2014-01-10 05:16:46 EST
Verified the presence of the fix in BPMS 6.0.0 ER7. However the sample project provided to reproduce the issue can no longer be built in business central. The error message states "org.kie.workbench.common.services.datamodeller.annotations.Label cannot be resolved to a type"

@ mbiarnes : If you want the bugfix to be verified against your sample project, please update your sample project and set the bugzilla back to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.