Bug 1013058 - system preferences display is completely maimed (may be caused by F18 alternate boot)
system preferences display is completely maimed (may be caused by F18 alterna...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-desktop (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 13:42 EDT by Endre "Hrebicek" Balint-Nagy
Modified: 2017-12-06 06:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:24:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Endre "Hrebicek" Balint-Nagy 2013-09-27 13:42:14 EDT
Description of problem:
The Apply button in display preferences completely maimed - makes no real effect.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Workstation release 6.5 Beta (Santiago)
ATM unknown the involved components, my candidate list: the nouveau kernel module or xorg-x11-drv-nouveau-1.0.1-4.el6.x86_64
How reproducible:
On my desktop system always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Endre "Hrebicek" Balint-Nagy 2013-09-27 15:56:22 EDT
Under completely maimed I mean no 'Keep this.' dialog appears and none of the changes takes effect, except on the imaginary monitors displayed.

Hmm, after some pondering I am more likely to believe in the rightfullness of accusing xorg-x11-drv-noveau package.
It is very sad, we have no error messages, the user (and I in particular) is left here in doubts and only guesswork remains.

Cheers
 Endre-Ondra
Comment 3 Ben Skeggs 2013-09-27 16:51:28 EDT
I have rather large doubts that nouveau is involved here, *especially* since you don't get a "Keep this" dialog box.  That'd suggest to me the application isn't doing anything.
Comment 4 Endre "Hrebicek" Balint-Nagy 2013-09-29 10:28:20 EDT
Ben,
Do you mean /usr/bin/gnome-display-properties, thus the control-center package?
(This is my third candidate to blame from start.)
While the VGA and DVB connectors were in use, no effect;after switching to HDMI connector it works. Somewhat strange. (BTW my personal issue is solved with changing output connector and using a HDMI->DVB cable).
Cheers
 Endre
Comment 5 Endre "Hrebicek" Balint-Nagy 2013-09-29 10:36:43 EDT
or I have to add changing from VGA output to HDMI. Sorry, I omitted this detail!
Comment 6 RHEL Product and Program Management 2013-10-13 19:05:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Endre "Hrebicek" Balint-Nagy 2013-11-18 20:24:30 EST
The issue lies around the gnome-settings-daemon.
At graphical login no gnome-settings-daemon is running and the display preferences setting is ignored (for me the left and right monitors are swapped). After running gnome-keyboard-properties, the monitors position is restored and the keyboard settings take effect (Before the en layout is selected alone, after the en, hu and ru are available). The gnome-settings-daemon is running thereafter.
The whole issue may be caused by a garbled startup-items setting.

Endre/Ondra.
Comment 9 Jan Kurik 2017-12-06 06:24:26 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.