Bug 101308 - installation can't find valid DASD device
installation can't find valid DASD device
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-30 15:16 EDT by Janet Smith
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 15:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Janet Smith 2003-07-30 15:16:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; .NET CLR 
1.0.3705)

Description of problem:
This is run under VM.  A dasd mini-disk has been provided and all of the dasd 
drivers & modules are properly loading, but the installation script doesn't 
recognize this and fails.

No hard drives have been found.   
You probably need to manually     
choose device drivers for the     
installation to succeed.  Would   
you like to select drivers now?   
                             

An error has occurred - no valid devices   
were found on which to create new file     
systems. Please check your hardware for    
the cause of this problem.            

Version-Release number of selected component (if applicable):
this is an problem with the redhat installation

How reproducible:
Always

Steps to Reproduce:
1.provide a VM minidisk to linux image
2.run install process
3.
    

Actual Results:  Although the dasd drives and modules are loaded, the 
installation can't seem to recognize a DASD device as a proper medium to 
install onto.

Expected Results:  installation should have allow dasdfmt & mke2fs (or other 
filesystem types) to be formatted and used

Additional info:

I can provide the console log.
Comment 1 Janet Smith 2003-07-30 19:02:44 EDT
I've figured a way around this problem.  If I manually, perform some linux 
function against the dasd device (dasdfmt, dd or mke2fs) then the anaconda 
installation will recognize that the device exist and says that it is of an 
improper format.  However this will allow the process to continue, with the 
anaconda installation performing the dasdfmt & mke2fs properly.  By the way, 
I'm using the text installation (python???).

You can close this problem if you want to.
Comment 2 Jeremy Katz 2003-07-31 19:07:50 EDT
Did you pass any DASD= command line arguments in your parm file or rely on dasd
autodetection?
Comment 3 Janet Smith 2003-07-31 19:09:41 EDT
I tried it both ways.
Comment 4 Karsten Hopp 2003-08-01 04:48:57 EDT
Did you format the minidisk in VM ? If so, with which program and parameters ? 
Or was this a reused minidisk, maybe in CMS format ? The installer ignores CMS formatted 
disks to avoid formatting the guests home disk or other writable system disks that happen  
to be in the DASD range you've provided in the .parm file. 
 
Comment 5 Janet Smith 2003-08-01 10:43:50 EDT
If was a newly created CMS formatted mini-disk.  I find that if I CMS format 
them then I don't have to do the dasdfmt & fdisk.  

But thanks for the resolution.  Just one observation, the error message was not 
very helpful in identifying the problem/issue.  Maybe a message a little more 
meaningful.

thanks
Comment 6 Jeremy Katz 2003-08-13 15:53:40 EDT
We're string frozen and the error message is correct (there isn't a suitable
device found).  I've passed this on to be included in the docuementation, though.

Note You need to log in before you can comment on or make changes to this bug.