Bug 1013093 - SY Quickstart "ear-deployment" fails during deploy
SY Quickstart "ear-deployment" fails during deploy
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER5
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 16:12 EDT by Pavel Drozd
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full log (16.11 KB, text/plain)
2013-09-27 16:12 EDT, Pavel Drozd
no flags Details

  None (edit)
Description Pavel Drozd 2013-09-27 16:12:09 EDT
Created attachment 804136 [details]
Full log

Following exception occurs during deploying the EAR:

22:05:29,543 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC000001: Failed to start service jboss.pojo."org.jboss.netty.internal.LoggerConfigurator".DESCRIBED: org.jboss.msc.service.StartException in service jboss.pojo."org.jboss.netty.internal.LoggerConfigurator".DESCRIBED: java.lang.ClassNotFoundException: org.jboss.netty.container.microcontainer.NettyLoggerConfigurator from [Module "deployment.switchyard-quickstart-ear-deployment-assembly-1.1.0.M3-redhat-1.ear:main" from Service Module Loader]
	at org.jboss.as.pojo.service.DescribedPojoPhase.startInternal(DescribedPojoPhase.java:73)
	at org.jboss.as.pojo.service.AbstractPojoPhase.start(AbstractPojoPhase.java:82)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146) [rt.jar:1.6.0_24]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.6.0_24]
	at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_24]
Caused by: java.lang.ClassNotFoundException: org.jboss.netty.container.microcontainer.NettyLoggerConfigurator from [Module "deployment.switchyard-quickstart-ear-deployment-assembly-1.1.0.M3-redhat-1.ear:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:196) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:399) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119) [jboss-modules.jar:1.2.0.Final-redhat-1]
	at java.lang.Class.forName0(Native Method) [rt.jar:1.6.0_24]
	at java.lang.Class.forName(Class.java:266) [rt.jar:1.6.0_24]
	at org.jboss.as.pojo.service.DescribedPojoPhase.startInternal(DescribedPojoPhase.java:69)
	... 6 more
Comment 1 Keith Babo 2013-10-15 11:45:53 EDT
This is due to a change in the version of maven-ear-plugin used in product vs. community.  In the community, the version is 2.8 as specified in the pom for the ear-assembly sub-project in the quickstart.  In FSW ER4, this version has been removed from the pom.xml and it appears to be inheriting 2.4.2 as the version.  Using mvn dependency:resolve-plugins reveals:

SwitchYard:
[INFO] Plugin Resolved: maven-ear-plugin-2.8.jar

FSW 6 ER4:
[INFO] Plugin Resolved: maven-ear-plugin-2.4.2-redhat-1.jar

Going back to version 2.4.2 effectively ignores the configuration of the plugin which excludes all jars from the dependency chain in the EAR assembly.  If you look at the content of the jar in the product build you'll see many, many jars included that should not be there, e.g.

ear-assembly$ jar -tvf target/switchyard-quickstart-ear-deployment-assembly-1.1.0.M3-redhat-2.ear 
     0 Tue Oct 15 10:43:52 EDT 2013 META-INF/
   124 Tue Oct 15 10:43:50 EDT 2013 META-INF/MANIFEST.MF
     0 Tue Oct 15 10:24:38 EDT 2013 lib/
 62247 Tue Oct 15 10:24:38 EDT 2013 activation-1.1.1-redhat-2.jar
  4467 Tue Oct 15 10:24:38 EDT 2013 aopalliance-1.0.jar
 43593 Tue Oct 15 10:24:38 EDT 2013 asm-3.3.1-redhat-4.jar
 12009 Tue Oct 15 10:24:38 EDT 2013 camel-cdi-2.10.0.redhat-60024.jar
2237377 Tue Oct 15 10:24:38 EDT 2013 camel-core-2.10.0.redhat-60024.jar
133483 Tue Oct 15 10:24:38 EDT 2013 camel-jms-2.10.0.redhat-60024.jar
 27775 Tue Oct 15 10:24:38 EDT 2013 camel-script-2.10.0.redhat-60024.jar
222343 Tue Oct 15 10:24:38 EDT 2013 camel-spring-2.10.0.redhat-60024.jar
 52255 Tue Oct 15 10:24:38 EDT 2013 cdi-api-1.0-SP4-redhat-2.jar
157326 Tue Oct 15 10:24:38 EDT 2013 codemodel-2.6-redhat-2.jar
 65085 Tue Oct 15 10:24:38 EDT 2013 commons-codec-1.4-redhat-2.jar
[snip ...]
Comment 2 Keith Babo 2013-10-16 20:35:44 EDT
Text for workaround:

The version of quickstarts/ear-deployment/ear-assembly/pom.xml shipped with FSW Beta contains the following definition for the maven-ear-plugin:

         <plugin>
                <artifactId>maven-ear-plugin</artifactId>
                <configuration>
                    <filtering>true</filtering>
            ….

The version element is missing to select the correct version of the plugin.  The user will need to add the <version> element like this:

          <plugin>
                <artifactId>maven-ear-plugin</artifactId>
                <version>2.8</version>
                <configuration>
                    <filtering>true</filtering>
            ….
Comment 3 Nick Cross 2013-10-17 09:19:03 EDT
Fixed in 6.0.0.Beta branch by 24d1996b8034bbd32dd72220090fa52d357a1b20/38d1ab77b45d9972263621a57e9c0e4f1247700a
Comment 4 Pavel Drozd 2013-10-18 05:52:18 EDT
Verified in FSW 6.0.0 ER6

Note You need to log in before you can comment on or make changes to this bug.