Bug 1013115 - rhc env set doesn't change the OPENSHIFT_MONGODB_DB_URL variable content
rhc env set doesn't change the OPENSHIFT_MONGODB_DB_URL variable content
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 17:18 EDT by Peter Ruan
Modified: 2015-05-14 19:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 10:00:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-09-27 17:18:23 EDT
Description of problem:
 rhc env set can't seem to set the OPENSHIFT_MONGODB_DB_URL



Version-Release number of selected component (if applicable):
current

How reproducible:
always

Steps to Reproduce:
1. create a any type app
2. add mongodb to the app
3. set the value of OPENSHIFT_MONGODB_DB_URL
rhc env set OPENSHIFT_MONGODB_DB_URL=mongodb://.../ -a $appname

Actual results:
the OPENHISFT_MONGODB_DB_URL did not get updated.

Expected results:


Additional info:
Comment 1 weiwei jiang 2013-09-29 02:00:19 EDT
Tried on devenv3844 with rhc-1.15.3 and can not reproduce.
Comment 2 Clayton Coleman 2013-09-30 10:00:19 EDT
Works for me on master

Note You need to log in before you can comment on or make changes to this bug.