Bug 1013138 - logconv.pl should handle microsecond timing
logconv.pl should handle microsecond timing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-09-27 17:55 EDT by Rich Megginson
Modified: 2014-10-14 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-09-27 17:55:51 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/539

When using the LDAP_DEBUG_TIMING access log level to collect microsecond etime timing, logconv.pl should be able to read this data and calculate statistics with microsecond resolution.

CBP would like this in rhel 6.5
Comment 3 srkrishn@redhat.com 2014-07-18 03:05:26 EDT
verified the microsecond timing bug.

[root@hp-ms-01-c04 srkrishn]# logconv.pl -t /var/log/dirsrv/slapd-hp-ms-01-c04/access | grep "etime=[0-9]*\.[0-9][0-9][0-9][0-9][0-9][0-9]"
111             etime=0.001000
62              etime=0.000000
18              etime=0.029000
17              etime=0.030000
15              etime=0.032000
13              etime=0.031000
13              etime=0.035000
11              etime=0.028000
10              etime=0.025000
10              etime=0.036000
8               etime=0.033000
8               etime=0.027000
7               etime=0.037000
7               etime=0.034000
6               etime=0.026000
4               etime=0.024000
4               etime=0.039000
4               etime=0.040000
4               etime=0.042000
etime=7.343000    1         
etime=0.089000    1         
etime=0.048000    1         
etime=0.045000    2         
etime=0.044000    1         
etime=0.042000    4         
etime=0.040000    4         
etime=0.039000    4         
etime=0.038000    3         
etime=0.037000    7         
etime=0.036000    10        
etime=0.035000    13        
etime=0.034000    7         
etime=0.033000    8         
etime=0.032000    15        
etime=0.031000    13        
etime=0.030000    17        
etime=0.029000    18        
etime=0.028000    11        
[root@hp-ms-01-c04 srkrishn]# 

this was verified on build 1.2.11.15-38-389-ds-base
Comment 4 Sankar Ramalingam 2014-07-23 08:18:33 EDT
Verified from automated acceptance tests.

microsecond timing has been successfully tracked by the logconv tool time1 =1               etime=0.016000
1               etime=0.025000
etime=0.025000    1         
etime=0.016000    1         
TestCase [logconv10] result-> [PASS]
Comment 5 errata-xmlrpc 2014-10-14 03:51:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.