Bug 1013141 - logconv.pl missing stats for starttls, ldapi, and autobind
logconv.pl missing stats for starttls, ldapi, and autobind
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-09-27 17:57 EDT by Rich Megginson
Modified: 2014-10-14 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:51:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-09-27 17:57:46 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/611

logconv.pl is missing stats for starttls, ldapi, and autobind connections.

CBP would like this in rhel 6.5
Comment 3 srkrishn@redhat.com 2014-07-19 02:07:53 EDT
this bug has been verified.

[root@hp-ms-01-c04 ~]# logconv.pl /var/log/dirsrv/slapd-hp-ms-01-c04/access.20140717-022403 


Total Log Lines Analysed:  3137903


----------- Access Log Output ------------

Start of Logs:    17/Jul/2014:02:43:12
End of Logs:      18/Jul/2014:01:48:40

Processed Log Time:  23 Hours, 5 Minutes, 28 Seconds

Restarts:                     92
Total Connections:            448316
 - StartTLS Connections:      0
 - LDAPS Connections:         0
 - LDAPI Connections:         0
Peak Concurrent Connections:  22
Total Operations:             896540
Total Results:                896540
Overall Performance:          100.0%

Searches:                     0             (0.00/sec)  (0.00/min)
Modifications:                0             (0.00/sec)  (0.00/min)
Adds:                         448224        (5.39/sec)  (323.52/min)
Deletes:                      0             (0.00/sec)  (0.00/min)
Mod RDNs:                     0             (0.00/sec)  (0.00/min)
Compares:                     0             (0.00/sec)  (0.00/min)
Binds:                        448316        (5.39/sec)  (323.58/min)

Proxied Auth Operations:      0
Persistent Searches:          0
Internal Operations:          0
Entry Operations:             0
Extended Operations:          0
Abandoned Requests:           0
Smart Referrals Received:     0

VLV Operations:               0
VLV Unindexed Searches:       0
VLV Unindexed Components:     0
SORT Operations:              0

Entire Search Base Queries:   0
Paged Searches:               0
Unindexed Searches:           0
Unindexed Components:         0

FDs Taken:                    448316
FDs Returned:                 448316
Highest FD Taken:             65

Broken Pipes:                 0
Connections Reset By Peer:    0
Resource Unavailable:         0
Max BER Size Exceeded:        0

Binds:                        448316
Unbinds:                      448316
 - LDAP v2 Binds:             0
 - LDAP v3 Binds:             448316
 - AUTOBINDs:                 0
 - SSL Client Binds:          0
 - Failed SSL Client Binds:   0
 - SASL Binds:                0
 - Directory Manager Binds:   0
 - Anonymous Binds:           0
 - Other Binds:               448316

this was tested on build : 1.2.11.15.38-389-ds-base
Comment 4 Sankar Ramalingam 2014-07-23 12:26:14 EDT
Marking the bug as Verified as per previous comment
Comment 5 errata-xmlrpc 2014-10-14 03:51:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.