Bug 1013156 - Refactor maven repository generation for EAP 6.2
Refactor maven repository generation for EAP 6.2
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Maven Repository (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ER4
: EAP 6.2.0
Assigned To: Paul Gier
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 19:00 EDT by Paul Gier
Modified: 2013-09-27 23:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 23:27:18 EDT
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Gier 2013-09-27 19:00:49 EDT
The current EAP 6.2 maven repository generation requires some changes due to two issues:

1. Manual updates are required to multiple config files for each ER release due to various parts of the repository being built and tested using different scripts and tools.  This adds some risk of forgetting to make an appropriate update in one of the files.  This configuration should be consolidated to a single config file where possible.

2. An older version of the maven-repository-builder project is used to download artifacts.  This should be updated to be more in sync with layered product maven repository generation.
Comment 1 Paul Gier 2013-09-27 19:01:47 EDT
In addition, there are some out of date scripts that are no longer used that can be removed..

Note You need to log in before you can comment on or make changes to this bug.