Bug 1013163 - logconv.pl uses /var/tmp for BDB temp files
logconv.pl uses /var/tmp for BDB temp files
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1013897 1061410
  Show dependency treegraph
 
Reported: 2013-09-27 19:37 EDT by Rich Megginson
Modified: 2014-10-14 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013897 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-09-27 19:37:55 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47501

Not sure why, but using logconv.pl -V with DB_File creates temporary DB files in /var/tmp called BDBxxxxx.  These can grow to be very, very large.  They need to go in the -D $dataLocation directory.

for CBP
Comment 3 srkrishn@redhat.com 2014-08-19 09:29:35 EDT
this bug has been verified as follows:
[root@hp-dl360g4-01 test]# logconv.pl -D /home/sk/ accesslog
[root@hp-dl360g4-01 home]# cd sk
[root@hp-dl360g4-01 sk]# ls
A1.logconv.db                      mdn_conn_op.logconv.db
abandon_conn_op.logconv.db         mod_conn_op.logconv.db
attr.logconv.db                    nentries_conn_op.logconv.db
B1.logconv.db                      nentries.logconv.db
B2.logconv.db                      notesa_conn_op.logconv.db
B3.logconv.db                      notesu_conn_op.logconv.db
B4.logconv.db                      oid.logconv.db
badpwd_conn_op.logconv.db          optype_conn_op.logconv.db
base.logconv.db                    P1.logconv.db
bind_conn_op.logconv.db            P2.logconv.db
bindlist.logconv.db                R1.logconv.db
cmp_conn_op.logconv.db             rc.logconv.db
conncount.logconv.db               rsrc.logconv.db
conn_hash.logconv.db               saslmech.logconv.db
del_conn_op.logconv.db             srch_conn_op.logconv.db
ds6xbadpwd.logconv.db              src.logconv.db
end_time_of_connection.logconv.db  start_time_of_connection.logconv.db
etime_conn_op.logconv.db           T1.logconv.db
etime.logconv.db                   T2.logconv.db
excount.logconv.db                 time_conn_op.logconv.db
ext_conn_op.logconv.db             U1.logconv.db

this was tested on 1.2.11.15.40
Comment 4 Sankar Ramalingam 2014-08-19 09:41:01 EDT
Based on previous comment from Sriram, marking it as Verified.
Comment 5 errata-xmlrpc 2014-10-14 03:51:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.