This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1013165 - logconv: some stats do not work across server restarts
logconv: some stats do not work across server restarts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On:
Blocks: 1013900 1061410
  Show dependency treegraph
 
Reported: 2013-09-27 19:41 EDT by Rich Megginson
Modified: 2014-10-14 03:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1013900 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2013-09-27 19:41:03 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47533

logconv keeps most stats in hashes keyed on connid,opid.  These are not unique - the server resets conn=1 upon restart.  logconv needs to keep unique stats across restarts.

for CBP
Comment 3 Sankar Ramalingam 2014-08-19 09:41:04 EDT
Its already automated in logconv tests.
Comment 4 Sankar Ramalingam 2014-08-19 09:52:35 EDT
Test cases are passing for logconv01. Hence, marking the bug as Verified

                                                                  
----------------- Starting Test logconv_01 -------------------------
Checking whether access log starts the connection as conn=1 after restart
It is expected to start the first connection as conn=1 instead of conn=0
User-uid=logconvusr will be added to Suffix-ou=busers,dc=logconv,dc=com with gid_no-
adding new entry uid=logconvusr2,ou=busers,dc=logconv,dc=com

User 2 added successfully to ou=busers,dc=logconv,dc=com , return code, 0
User-uid=logconvusr will be added to Suffix-ou=busers,dc=logconv,dc=com with gid_no-
adding new entry uid=logconvusr1,ou=busers,dc=logconv,dc=com

User 1 added successfully to ou=busers,dc=logconv,dc=com , return code, 0
NEWSUPERIOR=ou=fusers,dc=logconv,dc=com, OLDRDN=uid=logconvusr1, NEWRDN=uid=newusr_conv1, OLDSUPERIOR=ou=busers,dc=logconv,dc=com
modifying RDN of entry uid=logconvusr1,ou=busers,dc=logconv,dc=com and/or moving it beneath a new parent


logconv01: expect=0 actual=0
PASS
NEWSUPERIOR=ou=fusers,dc=logconv,dc=com, OLDRDN=uid=logconvusr2, NEWRDN=uid=newusr_conv2, OLDSUPERIOR=ou=busers,dc=logconv,dc=com
modifying RDN of entry uid=logconvusr2,ou=busers,dc=logconv,dc=com and/or moving it beneath a new parent


logconv01: expect=0 actual=0
PASS
Restarting the directory server instance, Restart #1
logconv01: expect=0 actual=0
PASS
Connection status shows conn=1 for the first conenction after restart
TestCase [logconv01] result-> [PASS]
Restarting the directory server instance, Restart #2
logconv01: expect=0 actual=0
PASS
User-uid=logconvusrN will be added to Suffix-ou=busers,dc=logconv,dc=com with gid_no-
adding new entry uid=logconvusrN2,ou=busers,dc=logconv,dc=com

User 2 added successfully to ou=busers,dc=logconv,dc=com , return code, 0
User-uid=logconvusrN will be added to Suffix-ou=busers,dc=logconv,dc=com with gid_no-
adding new entry uid=logconvusrN1,ou=busers,dc=logconv,dc=com

User 1 added successfully to ou=busers,dc=logconv,dc=com , return code, 0
logconv01: expect=0 actual=0
PASS
NEWSUPERIOR=ou=fusers,dc=logconv,dc=com, OLDRDN=uid=logconvusrN1, NEWRDN=uid=newusr_convN1, OLDSUPERIOR=ou=busers,dc=logconv,dc=com
modifying RDN of entry uid=logconvusrN1,ou=busers,dc=logconv,dc=com and/or moving it beneath a new parent


logconv01: expect=0 actual=0
PASS
NEWSUPERIOR=ou=fusers,dc=logconv,dc=com, OLDRDN=uid=logconvusrN2, NEWRDN=uid=newusr_convN2, OLDSUPERIOR=ou=busers,dc=logconv,dc=com
modifying RDN of entry uid=logconvusrN2,ou=busers,dc=logconv,dc=com and/or moving it beneath a new parent


logconv01: expect=0 actual=0
PASS
Restarts:                     3
Restart count increased as per the number of restarts
TestCase [logconv01] result-> [PASS]
Comment 5 errata-xmlrpc 2014-10-14 03:51:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.