Bug 1013169 - org.jboss.logmanager module needs dependency on javax.api for the SocketFactory
org.jboss.logmanager module needs dependency on javax.api for the SocketFactory
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity urgent
: ER4
: EAP 6.2.0
Assigned To: James Perkins
Nikoleta Ziakova
Russell Dickenson
:
Depends On:
Blocks: eap62-beta-blockers
  Show dependency treegraph
 
Reported: 2013-09-27 19:46 EDT by James Perkins
Modified: 2013-12-15 11:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:55:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2177 Major Resolved org.jboss.logmanager module needs dependency on javax.api for the SocketFactory 2014-08-13 06:51:02 EDT

  None (edit)
Description James Perkins 2013-09-27 19:46:00 EDT
The javax.net.SocketFactory is part of the javax.api module. Since the org.jboss.logmanager uses this for the syslog handler on TCP and SSL connections, a dependency on the module is needed.
Comment 2 James Perkins 2013-09-27 19:50:25 EDT
I should add this is only an issue if using the syslog handler with TCP for the protocol on a custom-handler.
Comment 3 Ondrej Lukas 2013-09-30 07:46:48 EDT
Same issue is in audit-log in syslog-handler. Audit log has P0 and it could be customer problem in Beta, because it couldn't be set and used by customer. For that reason it is candidate on Beta blocker. PR sent by James solves this issue.
Comment 4 JBoss JIRA Server 2013-09-30 13:19:55 EDT
James Perkins <jperkins@redhat.com> made a comment on jira WFLY-2177

Pull request merged
Comment 6 Petr Kremensky 2013-10-04 08:30:36 EDT
Verified on EAP 6.2.0.ER4

Note You need to log in before you can comment on or make changes to this bug.