Bug 1013173 - [abrt] git-svn-1.8.3.1-3.fc20: apr_allocator_destroy: Process /usr/bin/perl was killed by signal 6 (SIGABRT)
[abrt] git-svn-1.8.3.1-3.fc20: apr_allocator_destroy: Process /usr/bin/perl w...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libserf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:df80b8914845317ca28885135c0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 20:14 EDT by Petr Muller
Modified: 2016-09-19 22:10 EDT (History)
8 users (show)

See Also:
Fixed In Version: libserf-1.3.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 09:37:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.43 KB, text/plain)
2013-09-27 20:14 EDT, Petr Muller
no flags Details
File: cgroup (159 bytes, text/plain)
2013-09-27 20:14 EDT, Petr Muller
no flags Details
File: core_backtrace (4.65 KB, text/plain)
2013-09-27 20:14 EDT, Petr Muller
no flags Details
File: dso_list (6.82 KB, text/plain)
2013-09-27 20:14 EDT, Petr Muller
no flags Details
File: environ (3.15 KB, text/plain)
2013-09-27 20:15 EDT, Petr Muller
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-27 20:15 EDT, Petr Muller
no flags Details
File: maps (32.14 KB, text/plain)
2013-09-27 20:15 EDT, Petr Muller
no flags Details
File: open_fds (323 bytes, text/plain)
2013-09-27 20:15 EDT, Petr Muller
no flags Details
File: proc_pid_status (939 bytes, text/plain)
2013-09-27 20:15 EDT, Petr Muller
no flags Details

  None (edit)
Description Petr Muller 2013-09-27 20:14:39 EDT
Description of problem:
Doing a 'git svn rebase'. It seems to be reproducible.

Version-Release number of selected component:
git-svn-1.8.3.1-3.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/perl /usr/libexec/git-core/git-svn rebase
crash_function: apr_allocator_destroy
executable:     /usr/bin/perl
kernel:         3.11.1-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #5 apr_allocator_destroy at memory/unix/apr_pools.c:152
 #6 apr_pool_destroy at memory/unix/apr_pools.c:864
 #7 apr_pool_terminate at memory/unix/apr_pools.c:639
 #8 apr_terminate at misc/unix/start.c:82
 #9 _wrap_apr_terminate at core.c:2590
 #10 Perl_pp_entersub at pp_hot.c:2881
 #11 Perl_runops_standard at run.c:42
 #12 Perl_call_sv at perl.c:2766
 #13 Perl_call_list at perl.c:4863
 #14 perl_destruct at perl.c:558
Comment 1 Petr Muller 2013-09-27 20:14:45 EDT
Created attachment 804225 [details]
File: backtrace
Comment 2 Petr Muller 2013-09-27 20:14:51 EDT
Created attachment 804226 [details]
File: cgroup
Comment 3 Petr Muller 2013-09-27 20:14:54 EDT
Created attachment 804227 [details]
File: core_backtrace
Comment 4 Petr Muller 2013-09-27 20:14:58 EDT
Created attachment 804228 [details]
File: dso_list
Comment 5 Petr Muller 2013-09-27 20:15:02 EDT
Created attachment 804229 [details]
File: environ
Comment 6 Petr Muller 2013-09-27 20:15:08 EDT
Created attachment 804230 [details]
File: limits
Comment 7 Petr Muller 2013-09-27 20:15:12 EDT
Created attachment 804231 [details]
File: maps
Comment 8 Petr Muller 2013-09-27 20:15:16 EDT
Created attachment 804232 [details]
File: open_fds
Comment 9 Petr Muller 2013-09-27 20:15:20 EDT
Created attachment 804233 [details]
File: proc_pid_status
Comment 10 Dhiru Kholia 2013-11-13 05:31:27 EST
Upgrading to "serf-1.3.2" fixes this problem. Can we please do so?


("serf-1.3.1" requires an additional patch to fix this problem, see https://bugs.archlinux.org/task/36070)
Comment 11 Adam Tkac 2013-12-18 09:36:16 EST
(In reply to Dhiru Kholia from comment #10)
> Upgrading to "serf-1.3.2" fixes this problem. Can we please do so?
> 
> 
> ("serf-1.3.1" requires an additional patch to fix this problem, see
> https://bugs.archlinux.org/task/36070)

Reassigning to libserf.
Comment 12 Adam Tkac 2013-12-18 09:37:17 EST
libserf-1.3.2-1.fc20 is already in F20 updates, closing this issue.

Note You need to log in before you can comment on or make changes to this bug.