Bug 1013183 - [ml_IN] Samvruthokaram ligature is wrong
[ml_IN] Samvruthokaram ligature is wrong
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-malayalam-fonts (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-27 23:27 EDT by Pravin Satpute
Modified: 2014-03-04 01:40 EST (History)
8 users (show)

See Also:
Fixed In Version: lohit-malayalam-fonts-2.92.0-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 01:40:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image showing accepted and not-accepted rendering (44.21 KB, image/png)
2013-09-28 11:42 EDT, Pravin Satpute
no flags Details

  None (edit)
Description Pravin Satpute 2013-09-27 23:27:04 EDT
Description of problem:
Samvruthokaram ligature should not happen

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
ligature is happening with VS_U + VIRAWA. 

Expected results:
Ligature should not happen

Additional info:
Comment 1 Shriramana Sharma 2013-09-28 06:02:23 EDT
By using this great feature that is git bisect, I found out that the strange glyph was introduced in commit 2b6ab63152a3ef80a0e2c45b445cefd1b5463b2d by one Rahul Bhalerao. In the commit message it says "Bug fix for Lohit Malayalam" but there is no reference to any bugzilla item. Is it possible to contact this Rahul Bhalerao and find out why this glyph was added and based on what attestation?

@Pravin: shouldn't you add [ml_IN] to the title of the bug?
Comment 2 Pravin Satpute 2013-09-28 11:42:40 EDT
Created attachment 804455 [details]
Image showing accepted and not-accepted rendering

First on is current rendering of Lohit (which is wrong as per reproted). Bottom image showing correct rendering.
Comment 3 Santhosh Thottingal 2013-09-29 05:00:44 EDT
This change was done in a meeting at FOSS.in(2008 IIRC). Rahul, Suresh P and some of SMC members were there in a bug triage meet up. Samvruthokaram is aesthetically bad in modern orthography font(at least as per the participants of that meeting) and mainly found in traditional orthography. P Suresh proposed a rendering that is close to virama, but show a small visual difference just to identify it is Samvruthokaram. It was accepted and the change was done in that meeting. Never heard anybody complaining about that rendering in past 5 years. In short, it was a conscious decision by font maintainer at that time.
Comment 4 Shriramana Sharma 2013-09-29 11:03:35 EDT
Yes the commit by Rahul is dated Thu Feb 28 12:55:10 2008. So far nobody has complained probably because nobody writes Samvruthokaram nowadays. Cibu and I were specifically discussing updates to the Unicode chapter on Malayalam discussing Samvruthokaram and because of that we have come across this problem.

However, I do not understand on what basis you people considered it appropriate to introduce a new glyph in the font. Lohit fonts (which are used as system display fonts for Indic in most modern distros) are not the correct forum to bring about script reform or to invent new glyphs as part of a script. 

Malayalis are free to reform their script (like they did with the "putiya lipi" by breaking down the VS-U etc) but Malayalis are not the only people using the Malayalam script. Anyone can be interested in the Malayalam language and script and hence want to use it for whatever legitimate purpose. In this case, the academically accepted and attested form of the script is the only standard script to adhere to by all those concerned.

The Lohit fonts which are for common Malayalam use for all people should reflect the script *as it is attested*. People who are not aware of and have not agreed to the private agreement of a few people in such a meeting will certainly not recognize such a ligature. 

Since this is clearly NOT part of the commonly accepted and attested orthography of Malayalam, I would have to insist on the removal of this ligature which is unknown to anyone other than those who who attended that meeting, unaccepted by academic communities and undocumented in Unicode or any other academic sources. People who by private agreement wish to use their newly invented ligature can always have their forked version of Lohit Malayalam.
Comment 5 Santhosh Thottingal 2013-09-29 23:06:21 EDT
Correcting some facts:

(In reply to Shriramana Sharma from comment #4)
> probably because nobody writes Samvruthokaram nowadays.

I myself use it in daily use and I know a number of people using it. Bill boards in street using this is not rare. Agreed the usage is minimal.
 
> Cibu and
> I were specifically discussing updates to the Unicode chapter on Malayalam
> discussing Samvruthokaram and because of that we have come across this
> problem.

Great. Hope you will discuss/share with communities.

> However, I do not understand on what basis you people considered it
> appropriate to introduce a new glyph in the font. Lohit fonts (which are
> used as system display fonts for Indic in most modern distros) are not the
> correct forum to bring about script reform or to invent new glyphs as part
> of a script. 

Lohit Malayalam is not the system default font for ml in any distros I know. It is packaged in most of the distros.

I would leave it to the font maintainer to decide on this. I am ok with keeping the glyph or removing it.
Comment 6 Pravin Satpute 2013-09-29 23:40:03 EDT
Yeah, Lohit is not default for Malayalam as community prefers Old script fonts. So it is Meera now in Fedora and other open source distros.

But i think point is not whether Lohit is default or not. Lohit fonts project always tried to be compliant with the standards so other fonts (upcoming) projects can refer it and be assure that they are compliant with standards. (Unicode compliance, Script behaviour compliance)

As mentioned by Shriramana since there is no attestation available i am in favour of reverting this change. 

But same time as this decision was done by community with proper discussion, it definitely has weight and i will recommend to have some more debate openly and push it as in script reforms may be.
Comment 7 Shriramana Sharma 2013-09-30 12:27:11 EDT
(In reply to Santhosh Thottingal from comment #5)
> Correcting some facts:
> 
> (In reply to Shriramana Sharma from comment #4)
> > probably because nobody writes Samvruthokaram nowadays.
> 
> I myself use it in daily use and I know a number of people using it. Bill
> boards in street using this is not rare. Agreed the usage is minimal.

I am aware that the Samvruthokaram *sound* occurs regularly as part of Malayalam. I was however given to know that the VS-U + Chandrakala form of *writing* the Samvruthokaram is rare. In any case, the question is whether this samvruthokaram ligature enjoys attestation/acceptance among the widespread Malayali scholarly/otherwise community or not.

> Lohit Malayalam is not the system default font for ml in any distros I know.
> It is packaged in most of the distros.

OK on this apparently I was wrong.

(In reply to Pravin Satpute from comment #6)
> But i think point is not whether Lohit is default or not. Lohit fonts
> project always tried to be compliant with the standards so other fonts
> (upcoming) projects can refer it and be assure that they are compliant with
> standards. (Unicode compliance, Script behaviour compliance)

Exactly. None of these standards seem to give attestation for this.

> But same time as this decision was done by community with proper discussion,
> it definitely has weight and i will recommend to have some more debate
> openly and push it as in script reforms may be.

I beg to differ. It was the decision/invention of a few people who were attending the FOSS.in conference in 2008. It was not the decision of Kerala Govt or Malayalam language academia or Malayali public. So it's entirely different.

If I talk to some of my technically knowledgeable friends and invent a new Tamil ligature for J-NYA will you publish it as part of Lohit Tamil? Certainly not, because it is not accepted as part of recognized Tamil script. Likewise this should be treated and the ligature removed forthwith, IMO. Those who like to have the ligature for their private preference/usage can always have a forked version of Lohit Malayalam on their computer.
Comment 8 Pravin Satpute 2013-09-30 14:31:17 EDT
I will fix this bug and other open issue in this week and do the minor release of lohit malayalam.
Comment 9 Fedora Update System 2013-10-08 04:49:36 EDT
lohit-malayalam-fonts-2.5.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.5.4-1.fc19
Comment 10 Fedora Update System 2013-10-08 04:53:09 EDT
lohit-malayalam-fonts-2.5.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.5.4-1.fc20
Comment 11 Fedora Update System 2013-10-09 10:29:03 EDT
Package lohit-malayalam-fonts-2.5.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-malayalam-fonts-2.5.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18548/lohit-malayalam-fonts-2.5.4-1.fc20
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-10-22 23:28:33 EDT
lohit-malayalam-fonts-2.5.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2014-02-05 01:01:39 EST
lohit-malayalam-fonts-2.91.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.91.0-1.fc20
Comment 14 Pravin Satpute 2014-02-05 01:12:16 EST
Unfortunately, this came as a regression in 2.91.0. Already resolved in upstream (https://github.com/pravins/lohit/issues/37) and will be available with new release.
Comment 15 Fedora Update System 2014-02-19 00:05:01 EST
lohit-malayalam-fonts-2.92.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lohit-malayalam-fonts-2.92.0-1.fc20
Comment 16 Fedora Update System 2014-02-21 19:56:49 EST
Package lohit-malayalam-fonts-2.92.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-malayalam-fonts-2.92.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2861/lohit-malayalam-fonts-2.92.0-1.fc20
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2014-03-04 01:40:23 EST
lohit-malayalam-fonts-2.92.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.