Bug 1013200 - NetworkManager-openvpn fails to establish connection on imported (via NM-gnome) vpn config (client.conf)
NetworkManager-openvpn fails to establish connection on imported (via NM-gnom...
Status: CLOSED DUPLICATE of bug 1018317
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-28 05:11 EDT by Dominik Grafenhofer
Modified: 2013-11-16 20:16 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 12:54:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
client.conf (180 bytes, text/plain)
2013-09-28 05:11 EDT, Dominik Grafenhofer
no flags Details
log extracted with journalctl (4.10 KB, text/x-log)
2013-09-30 11:07 EDT, Dominik Grafenhofer
no flags Details

  None (edit)
Description Dominik Grafenhofer 2013-09-28 05:11:17 EDT
Created attachment 804374 [details]
client.conf

Description of problem:

I am importing openvpn client settings (client.conf, ca.crt, client.crt, client.key) with NM-gnome. After working around a SElinux issue (#638691), connecting to the vpn still fails. The same procedure works flawlessly on ubuntu 13.04 (nm 0.9.8, openvpn 2.2.1).


Gnome error message:

Connection failed: Activation of network connection failed


journald log messages (excerpt):

WARNING: No server certificate verification method has been enabled.
NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
<warn> VPN connection 'xxcensoredx' did not receive valid IP config information
<warn> (tun0): failed to get device's ifindex

then lots of the following messages (and slight variants of it):
[platform/nm-linux-platform.c:1103] add_object(): Netlink error: Invalid address for specified address family


Version-Release number of selected components:

openvpn-2.3.2-4.fc20
NetworkManager-openvpn-0.9.8.2-3.fc20
NetworkManager-openvpn-gnome-0.9.8.2-3.fc20
Comment 1 Dominik Grafenhofer 2013-09-29 02:59:00 EDT
This seems to be a NM issue, because invoking 

openvpn --config client.conf

establishes the vpn connection.
Comment 2 Jirka Klimes 2013-09-30 05:57:52 EDT
Would you attach full log (from NetworkManager staring, and showing VPN connection attempt)?
* What is your NetworkManager version?
* ip link
Comment 3 Dominik Grafenhofer 2013-09-30 11:06:30 EDT
1) NetworkManager-0.9.9.0-12.git20130913.fc20
2) ip link: usb3 gigabit ethernet card Digitus DN-3023, driver ax88179. home ADSL behind router
3) ip link alternative: same home ADSL connection via WIFI (Intel)
4) logs see attachment journal_censored.log
Comment 4 Dominik Grafenhofer 2013-09-30 11:07:09 EDT
Created attachment 805253 [details]
log extracted with journalctl
Comment 5 Jiri Slivarich 2013-10-08 06:30:24 EDT
This happens to me also. Workaround with Terminal invocation is working.
Comment 6 Dan Williams 2013-10-16 12:54:46 EDT

*** This bug has been marked as a duplicate of bug 1018317 ***

Note You need to log in before you can comment on or make changes to this bug.