Bug 1013236 - System tab is unavailable for non-root user. (The root access pop-up is not displayed.)
System tab is unavailable for non-root user. (The root access pop-up is not d...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-28 12:45 EDT by Peter Trenholme
Modified: 2016-11-30 19:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 12:11:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2013-09-28 12:45:35 EDT
Description of problem: When gnome-abrt is started by a non-root user, the system aborts tab is displayed with the number of system aborts, but clicking on the tab does not pop the password request box, so the only way to see those aborts is to start gnome-sbrt from a terminal as root. (See the notes below.)

Version-Release number of selected component (if applicable):
Not available (see below), but the latest update in the rawhide repository.

How reproducible: Every time 


Steps to Reproduce:
1.Run gnome-abrt
2.Click on the system tab
3.

Actual results:
No action

Expected results:
Access needed pop-up displayed

Additional info:
1) The --version option is not recognized by gnome-abrt
2) gnome-abrt terminal output when run as gnome-abrt -v:
$ gnome-abrt -v
error: XDG_RUNTIME_DIR not set in the environment.
DEBUG:root:User dismissed D-Bus authentication
3) Note: The DEBUG message was displayed when I clicked on the system tab.
Comment 1 Jakub Filak 2013-09-30 10:16:06 EDT
Thank you for the bug report. I'm afraid that this is not a bug in gnome-abrt because the app is not primarily responsible for showing the password dialogue. To be completely sure which program causes this unwanted behaviour, please run the following command and report the results here:

$ dbus-send --system --type=method_call --print-reply --dest=org.freedesktop.problems /org/freedesktop/problems org.freedesktop.problems.GetAllProblems


At least, the password dialogue should appear.
Comment 2 Peter Trenholme 2013-09-30 12:18:30 EDT
OK, I did that and the pop-up was displayed. Here's the output:

--------------------------------------------------------------

$ dbus-send --system --type=method_call --print-reply --dest=org.freedesktop.problems /org/freedesktop/problems org.freedesktop.problems.GetAllProblems
method return sender=:1.81 -> dest=:1.80 reply_serial=2
   array [
      string "/var/tmp/abrt/ccpp-2013-09-28-16:37:30-18773"
      string "/var/tmp/abrt/ccpp-2013-09-28-22:13:31-21994"
   ]

$ sudo cat /var/tmp/abrt/last-ccpp 
/usr/bin/pulseaudio

$ sudo cat /var/tmp/abrt/last-via-server 
/usr/share/yumex/backend-launcher.py

-------------------------------------------------------------

Both of those are "user" aborts. After I first posted this bug, I did a
sudo gnome-abrt, looked at the system problems, and cleared them. (They were both related to the system hanging when attempting a reboot or shutdown. I think that's a configuration problem since it only happens on my F19 [now F20 via fedup] system, but not on my Rawhide one.)
Comment 3 Peter Trenholme 2013-09-30 12:41:11 EDT
I just killed a hung yumex, and, when I looked at the abrt (from the tray applet), the expected pop-up WAS displayed. So I guess that this is now moot.
Comment 4 Jakub Filak 2013-10-09 12:11:40 EDT
(In reply to Peter Trenholme from comment #3)
> I just killed a hung yumex, and, when I looked at the abrt (from the tray
> applet), the expected pop-up WAS displayed. So I guess that this is now moot.

It seems that it was a mysterious bug either in abrt-dbus or in polkit. I am closing this report as NOTABUG but please feel free to reopen the bug report if you experience it again.

Note You need to log in before you can comment on or make changes to this bug.