Bug 1013294 - Unable to create SSH session for application 'main' Auth fail
Unable to create SSH session for application 'main' Auth fail
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
x86_64 Windows
unspecified Severity urgent
: ---
: ---
Assigned To: Max Rydahl Andersen
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 02:45 EDT by edzordzinam
Modified: 2015-05-14 19:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 17:25:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshots of app details with error (382.59 KB, application/pdf)
2013-09-29 02:45 EDT, edzordzinam
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBIDE-15679 Blocker Closed Unable to create SSH session for application 'main' Auth fail 2014-01-19 21:19:47 EST

  None (edit)
Description edzordzinam 2013-09-29 02:45:40 EDT
Created attachment 804625 [details]
Screenshots of app details with error

Description of problem:

After having problem with Jboss Openshifts 4.0 not being able to connect to openshift servers resolved by a recent update, now I have three applications on a domain. Am able to manage two of those application but one always returns "Unable to create SSH session for application 'main' Auth fail" whenever I try to manage the application with JBoss openshift tools for Zend Studio. After investigating for a while I noticed that the UUID for the two applications are was able to access were the same as the username in the git url. However for the one that am unable to access the UUID is different from the username in the git url. Management with rhc and other ssh tools work but I need the JBoss tools because they make work easier. Is there any way I can update the UUID in JBoss Openshift tools.

Version-Release number of selected component (if applicable):


How reproducible:
This error is unique because all the other applications in the domain greports.rhcloud.com with the exception of main-greports.rhcloud.com do not have the problem reported. However, the application concerned was created so many months before the others hence could be a problem associated with openshift updates.

Steps to Reproduce:
1. Using Openshift tools in zend studio, in the openshift explorer window, any attempts to portforward, tail files, or view environment details fail. However, server publish from the corresponding server adapter works without a problem. It is also to note that all the above functionalities work when I use rhc. View details of app however indicate to me that the UUID as reported by openshift online is different from the username of the git url for the app concerned. (main-greports.rhcloud.com)

2. when tailing files from openshift explorer tools the error message indicates that openshift tools was using the mismatched UUID as the username in attempting to authenticate with app which is actually the wrong username for the git / ssh url.

Actual results:


Expected results:


Additional info:
Comment 1 Lili Nader 2013-09-30 16:05:45 EDT
Further debugging is required by the jboss tools team to figure out what is going on.
Comment 2 Dan McPherson 2013-10-03 13:47:50 EDT
This sound like you might be using the wrong uuid.  Namely that you are using the app uuid instead of the gear uuid.  Is that possible?
Comment 3 weiwei jiang 2013-10-09 03:29:37 EDT
Tried on INT(devenv_stage_488) and PROD via JBDS 7.0.GA, but I can not make app UUID different with gear UUID, so can not reproduce this issue.
Comment 4 Andre Dietisheim 2013-10-11 10:45:45 EDT
sorry we're in a big rush currently towards JBDS7.1 Beta (next thursday). I dont have any time left for this unfortuantely, otherwise we'll not able to make it. I kindly ask you to be patient with this until after our freeze. If this is not possible, then please re-ping me.
Comment 5 manoj 2013-10-11 11:29:47 EDT
Max,

Please look at this as soon as you can
Comment 6 Andre Dietisheim 2013-10-16 13:25:42 EDT
We tackled this in JBIDE-15679 (cant link it, missing the permissions). This is resolved and fixed in JBDS, will get released in the upcoming 7.1
Comment 7 Andre Dietisheim 2013-10-16 14:46:56 EDT
can you please link JBIDE-15679 in this issue? (I cannot, I dont have the priviledges since I'm not the reporter)
Comment 8 JBoss JIRA Server 2013-11-07 08:20:42 EST
Marián Labuda <mlabuda@redhat.com> updated the status of jira JBIDE-15679 to Closed
Comment 9 JBoss JIRA Server 2013-11-07 08:20:42 EST
Marián Labuda <mlabuda@redhat.com> made a comment on jira JBIDE-15679

Verified in JBDS 7.1.0.Beta1
Build id: Beta1-v20131102-1529-B493

Note You need to log in before you can comment on or make changes to this bug.