Bug 101339 - Statically linked Apache crashes in initgroups when using OpenLDAP
Summary: Statically linked Apache crashes in initgroups when using OpenLDAP
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 23:06 UTC by szaka
Modified: 2016-11-24 14:56 UTC (History)
2 users (show)

Fixed In Version: 2.3.2-56
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 15:52:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description szaka 2003-07-30 23:06:49 UTC
Description of problem:
Statically linked Apache children immdiately crash (sig11) in glibc's initgroups
when using OpenLDAP.

Version-Release number of selected component (if applicable):
latest glibc and openldap shipped by Red Hat 9. The glibc errata didn't fix the
problem.

How reproducible:
Always

Steps to Reproduce:
1. install openldap
2. make sure the 'group' line in /etc/nsswitch.conf is 'file ldap'
3. echo "main(){initgroups("root",0);} > a.c ; gcc --static a.c
4. ./a.out
segmentation fault


Actual Results:  segmentation fault

Expected Results:  no segmentation fault

Comment 1 Jakub Jelinek 2003-07-31 15:52:00 UTC
Works for me in glibc-2.3.2-56.
Also, it gives a new link time warning:
Using 'initgroups' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
as using NSS/iconv in statically linked programs is really bad idea.


Note You need to log in before you can comment on or make changes to this bug.