Bug 1013397 - Unable to boot with btrfs root partition after upgrade to 3.10.12-100
Unable to boot with btrfs root partition after upgrade to 3.10.12-100
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-29 18:37 EDT by Marcin Zajaczkowski
Modified: 2013-10-01 16:14 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 16:14:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Zajaczkowski 2013-09-29 18:37:45 EDT
Description of problem:
I upgraded a kernel from 3.9.11-200 to 3.10.12-100.fc18.x86_64 and I'm dropping into the emergency shell on boot. In the log I see:
dracut-initqueue[243]: mount: unknown filesystem type 'btrfs'
I have boot partition ext4 and *root* partition btrfs. I tried to regenerate an image file with dracut:
dracut --kver 3.10.12-100.fc18.x86_64 --force
but with no effect. I can still boot using previous 3.9.11 kernel. 

Version-Release number of selected component (if applicable):
3.10.12-100.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to 3.10.12-100
2. Try to boot using this kernel version

Actual results:
The emergency shell with the following error message in the log:
dracut-initqueue[243]: mount: unknown filesystem type 'btrfs'

Expected results:
boot without problems

Additional info:
It seems I'm not the only one who had this problem http://www.reddit.com/r/Fedora/comments/1k1nvx/fedora_19_anyone_else_having_trouble_booting_w/ , but I haven't found a bug report or a solution.
Comment 1 Josh Boyer 2013-09-30 11:05:22 EDT
Please provide the output of:

lsinitrd /boot/initramfs-3.10.12-100.fc18.x86_64.img | grep btrfs

and also the output of dmesg on a failing boot.  You should be able to save that into the /boot partition from the dracut shell.
Comment 2 Marcin Zajaczkowski 2013-09-30 11:41:21 EDT
$ sudo lsinitrd /boot/initramfs-3.10.12-100.fc18.x86_64.img | grep btrfs
-rw-r--r--   1 root     root          392 Aug 19 01:31 etc/udev/rules.d/80-btrfs.rules
drwxr-xr-x   1 root     root            0 Aug 19 01:31 usr/lib/modules/3.10.12-100.fc18.x86_64/kernel/fs/btrfs
-rw-r--r--   1 root     root      1290343 Aug 19 01:31 usr/lib/modules/3.10.12-100.fc18.x86_64/kernel/fs/btrfs/btrfs.ko
-rwxr-xr-x   1 root     root       266720 Aug 19 01:31 usr/sbin/btrfs
-rwxr-xr-x   1 root     root       203552 Aug 19 01:31 usr/sbin/btrfsck
-rwxr-xr-x   1 root     root          707 Aug 19 01:31 usr/sbin/btrfs_finished
-rwxr-xr-x   1 root     root          256 Aug 19 01:31 usr/sbin/btrfs_timeout

(Aug 19 01:31 is a date when I rebuilded initramfs - I have problem with time synchronisation)

I will try to get the output of dmesg shortly.
Comment 3 Marcin Zajaczkowski 2013-10-01 12:20:32 EDT
Hmm, I'm not able to reproduce it anymore. Very strange. I did some kernel related changes in the mean time, but I don't know what could "fix" my problem. I attach a detailed information about my changes, maybe you will have some idea.

Everything was done after an initramfs image was regenerated and a try to boot with it failed (with the btrfs error).

I tried to install VirtualBox and I downgraded kernel-keaders to 3.9.11-200. I rebuilded vbox modules, but I was unable to load them due to "ERROR: could not insert 'vboxdrv': Required key not available". I disabled secure boot in BIOS and was able to use VirtualBox. Later I tried to reproduce a problem with btrfs but without success.
I reanabled secure boot, upgraded kernel-headers, but 3.10.12-100 still boots without problems.
Comment 4 Josh Boyer 2013-10-01 12:46:10 EDT
I have no idea.  If you can't recreate it now, we might as well close the bug.
Comment 5 Marcin Zajaczkowski 2013-10-01 16:14:18 EDT
In that case I'm closing the bug. Thanks for your support.

Note You need to log in before you can comment on or make changes to this bug.