Bug 10134 - i386 and SRPM not in sync
i386 and SRPM not in sync
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: dhcp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-12 12:08 EST by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-13 14:03:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-03-12 12:08:08 EST
The i386 and the SRPM are not in sync ... the i386 appears "older".  These
srouce and binary rpms were built on different systems:
i386(porky.devel.redhat.com) and src(porkchop.redhat.com).

This is also true for the piglet versions (which are the same
version/release).

The current src cannot be used to rebuild the current i386.

Gene
Comment 1 Jeff Johnson 2000-03-12 14:35:59 EST
All Red Hat src.rpm's show porkchop.redhat.com as the build host, while
all i386.rpm's show porky.devel.redhat.com as the build host, because
that's the way we build packages. The build times will differ, possibly
significantly, because the src.rpm is built before the i386.rpm, and
the machines may very well have different system times.

Without details regarding what package you are having trouble building,
it's impossible to guess at your problem. Please reopen this report
with specific details.
Comment 2 Gene Czarcinski 2000-03-12 18:07:59 EST
It appears to me that the build on the different systems are not in sync.

The i386.rpms is built but not from the supplied src.rpm because the "files"
section (and the changelog) indicate that compressed man files such as
/usr/man/man5/dhcpd.conf.5.gz are to be used but they do not exist in the
BuildRoot directory.  Instead, the uncompressed versions exist such as
/usr/man/man5/dhcpd.conf.5.  The i386.rpm cannot be built because of files
missing.  Yet, the i386.rpm package exists.

Obviously, the two build systems are a bit off.

Gene
Comment 3 Erik Troan 2000-03-13 14:03:59 EST
The compression happen as part of packaging; please make sure you're using
the latest version of rpm, which compresses man pages automatically.

Note You need to log in before you can comment on or make changes to this bug.