Bug 1013452 - It is not possible to change boot order for a VM from rhevm-shell.
It is not possible to change boot order for a VM from rhevm-shell.
Status: CLOSED DUPLICATE of bug 1012985
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
unspecified
All All
unspecified Severity medium
: ---
: ---
Assigned To: Michael Pasternak
Elena
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 02:31 EDT by Roman Hodain
Modified: 2014-01-12 20:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 02:34:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Hodain 2013-09-30 02:31:33 EDT
Description of problem:
It is not possible to change the boot-order of any VM with parameter --os-boot

Version-Release number of selected component (if applicable):
 - rhevm-cli-3.2.0.9-1
 - rhevm-3.2.2-0.41

How reproducible:
100%

Steps to Reproduce:
1. Crate a new VM
2. Set boot -order:

    # update vm TestVM --os-boot boot.dev=hd,boot.dev=cdrom 
       name                      : TestVM
       ...
       os-boot-dev               : hd
       os-boot-dev               : cdrom
       ...

3. Change the boot-order

    # update vm TestVM --os-boot boot.dev=cdrom,boot.dev=hd
       name                      : TestVM
       ...
       os-boot-dev               : hd
       os-boot-dev               : cdrom
       ...


Actual results:
The boot-order does not change

Expected results:
the boot order changes

Additional info:
This operation is done when the VM is down.
Comment 1 Roman Hodain 2013-09-30 02:34:04 EDT

*** This bug has been marked as a duplicate of bug 1012985 ***

Note You need to log in before you can comment on or make changes to this bug.