Bug 1013486 - Installation on AWS (CentOS) fails
Summary: Installation on AWS (CentOS) fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: npm
Version: el6
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: T.C. Hollingsworth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-09-30 08:13 UTC by Daniel Scott
Modified: 2013-09-30 18:45 UTC (History)
3 users (show)

Fixed In Version: nodejs-request-2.25.0-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-30 18:45:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Scott 2013-09-30 08:13:12 UTC
Description of problem:
Installation of npm on AWS (CentOS) fails with dependency errors.

--> Finished Dependency Resolution
Error: Package: nodejs-npm-registry-client-0.2.28-1.el6.noarch (epel)
           Requires: npm(semver) >= 2.1.0
           Installing: nodejs-semver-2.0.10-1.el6.noarch (epel)
               npm(semver) = 2.0.10
Error: Package: nodejs-request-2.21.0-1.el6.noarch (epel)
           Requires: npm(form-data) < 0.1
           Available: nodejs-form-data-0.1.1-1.el6.noarch (epel)
               npm(form-data) = 0.1.1
Error: Package: nodejs-request-2.21.0-1.el6.noarch (epel)
           Requires: npm(form-data) < 0.1
           Installing: nodejs-form-data-0.1.1-1.el6.noarch (epel)
               npm(form-data) = 0.1.1
Error: Package: nodejs-npm-registry-client-0.2.28-1.el6.noarch (epel)
           Requires: npm(request) >= 2.25.0
           Installing: nodejs-request-2.21.0-1.el6.noarch (epel)
               npm(request) = 2.21.0

So the problem appears to be that nodejs-request-2.21.0-1.el6.noarch requires nodejs-form-data < 0.1, but only version 0.1.1-1 is available.

Comment 1 Anssi Johansson 2013-09-30 08:18:33 UTC
Try 'yum install npm --enablerepo=epel-testing'.

Comment 2 Daniel Scott 2013-09-30 08:30:08 UTC
Thanks, that pulls in nodejs-request-2.25.0-3, which appears to fix the problem.

Does this mean that nodejs-request needs to be pushed stable ASAP?

Comment 3 Obsolete Account 2013-09-30 08:39:00 UTC
Yes, there are packages nodejs-request-2.25.0-3 and nodejs-semver-2.1.0-1 in the Fedora EPEL Testing 6 repository.

Please push them into the Fedora EPEL 6 repository ASAP to resolve this issue.

Thank you!

Comment 4 T.C. Hollingsworth 2013-09-30 12:50:33 UTC
Yeah, this got all messed up.  :-(

Please go to https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11191/ and log in with a Fedora account and provide karma so we can get this pushed stable.  Thanks!

Comment 5 Fedora Update System 2013-09-30 12:52:20 UTC
nodejs-request-2.25.0-3.el6, npm-1.3.6-4.el6, node-gyp-0.10.6-2.el6, nodejs-assert-plus-0.1.4-1.el6, nodejs-bindings-1.1.1-1.el6, nodejs-block-stream-0.0.7-1.el6, nodejs-cryptiles-0.2.2-1.el6, nodejs-fstream-0.1.24-1.el6, nodejs-glob-3.2.6-1.el6, nodejs-hawk-1.0.0-1.el6, nodejs-mute-stream-0.0.4-1.el6, nodejs-nopt-2.1.2-1.el6, nodejs-normalize-package-data-0.2.1-1.el6, nodejs-npmconf-0.1.2-1.el6, nodejs-read-1.0.5-1.el6, nodejs-read-package-json-1.1.1-1.el6, nodejs-rimraf-2.2.2-1.el6, nodejs-semver-2.1.0-1.el6, nodejs-sha-1.2.1-1.el6, nodejs-tar-0.1.18-1.el6, nodejs-inherits-2.0.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11191/nodejs-request-2.25.0-3.el6,npm-1.3.6-4.el6,node-gyp-0.10.6-2.el6,nodejs-assert-plus-0.1.4-1.el6,nodejs-bindings-1.1.1-1.el6,nodejs-block-stream-0.0.7-1.el6,nodejs-cryptiles-0.2.2-1.el6,nodejs-fstream-0.1.24-1.el6,nodejs-glob-3.2.6-1.el6,nodejs-hawk-1.0.0-1.el6,nodejs-mute-stream-0.0.4-1.el6,nodejs-nopt-2.1.2-1.el6,nodejs-normalize-package-data-0.2.1-1.el6,nodejs-npmconf-0.1.2-1.el6,nodejs-read-1.0.5-1.el6,nodejs-read-package-json-1.1.1-1.el6,nodejs-rimraf-2.2.2-1.el6,nodejs-semver-2.1.0-1.el6,nodejs-sha-1.2.1-1.el6,nodejs-tar-0.1.18-1.el6,nodejs-inherits-2.0.0-4.el6

Comment 6 T.C. Hollingsworth 2013-09-30 16:23:21 UTC
This update is now queued for stable.  The update system will automatically close this bug when it has been pushed stable by Release Engineering.

Thanks for the karma and sorry for the inconvenience.

Comment 7 Fedora Update System 2013-09-30 18:45:38 UTC
nodejs-request-2.25.0-3.el6, npm-1.3.6-4.el6, node-gyp-0.10.6-2.el6, nodejs-assert-plus-0.1.4-1.el6, nodejs-bindings-1.1.1-1.el6, nodejs-block-stream-0.0.7-1.el6, nodejs-cryptiles-0.2.2-1.el6, nodejs-fstream-0.1.24-1.el6, nodejs-glob-3.2.6-1.el6, nodejs-hawk-1.0.0-1.el6, nodejs-mute-stream-0.0.4-1.el6, nodejs-nopt-2.1.2-1.el6, nodejs-normalize-package-data-0.2.1-1.el6, nodejs-npmconf-0.1.2-1.el6, nodejs-read-1.0.5-1.el6, nodejs-rimraf-2.2.2-1.el6, nodejs-semver-2.1.0-1.el6, nodejs-sha-1.2.1-1.el6, nodejs-tar-0.1.18-1.el6, nodejs-inherits-2.0.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.