Bug 10135 - Bus Error on connect to www.dsl.net when NOT root
Bus Error on connect to www.dsl.net when NOT root
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-12 17:07 EST by Lincoln A. Baxter
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-18 12:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lincoln A. Baxter 2000-03-12 17:07:20 EST
I am running a RH6.0 system with the follow netscape RPMs installed:

rpm -qa | grep netscape
netscape-communicator-4.7-1.1
netscape-navigator-4.7-1.1
netscape-common-4.7-1.1

When I connect to http://www.dsl.net as me (a mortal) netscape crashes
with a Bus Error.  When I connect as root, the netscape displays the
whole page.  Running strace netscape (as me) shows that netscape is
attempting to mmap() a file but (according to the man page for mmap(),
passing a bad file descriptor (-1) when as I read this trace it should
have passed 40 as arg 5:

time(NULL)                              = 952897146
getpid()                                = 1745
stat("/home/lab/.netscape/cache/1A", {st_mode=0, st_size=0, ...}) = 0
stat("/home/lab/.netscape/cache/1A/cache38CC0E7A01406D1.js", 0xbfffe1c0) =
-1 ENOENT (No such file or directory)
open("/home/lab/.netscape/cache/1A/cache38CC0E7A01406D1.js",
O_WRONLY|O_CREAT|O_TRUNC, 0666) = 40
fchmod(40, 0600)                        = 0
fstat(40, {st_mode=0, st_size=0, ...})  = 0
mmap(0, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x402ad000
--- SIGSEGV (Segmentation fault) ---
getpid()                                = 1745
kill(1745, SIGBUS)                      = 0
--- SIGBUS (Bus error) ---
+++ killed by SIGBUS +++

I do not think this is a protection problem, since the open(), fchmod(),
and fstat()
calls all succeeded.  Some how it seems to have lost the descriptor.

As expected the file exists... has the expected mode, and is empty:

ls -l /home/lab/.netscape/cache/1A/cache38CC0E7A01406D1.js
-rw-------   1 lab      lab             0 Mar 12 16:39
/home/lab/.netscape/cache/1A/cache38CC0E7A01406D1.js


This does not appear to tbe the Font bug:

/usr/sbin/chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/share/fonts/default/Type1
8: /usr/X11R6/lib/X11/fonts/100dpi
9: /usr/X11R6/lib/X11/fonts/75dpi
Comment 1 Bill Nottingham 2000-03-20 12:18:59 EST
There seems to be some shockwave on that page - do you
have the shockwave plugin loaded as a user but not as root?
Comment 2 Lincoln A. Baxter 2000-03-20 21:43:59 EST
Not that I know of...  in any case, the program works as root and not
as a user. The user has empty .js files in the cache directories, and
root does not...

Since I reported this... I have failed (as either root or a user) to
connect to http://oreilly.linux.com/pub/a/linux/2000/03/10/netadmin/ddos.html
which whenn I connect using MS EI works... and seems to have a lot of those
stupid java animations...  I wonder if this is really still some kind of
java script bug (given the empty .js files).
Comment 3 Bill Nottingham 2000-03-30 12:05:59 EST
I still can't reproduce this here. What you might try
doing is installing the XFree86-libs package from 6.2; this
fixes a couple of bugs that can cause netscape crashes.

Note You need to log in before you can comment on or make changes to this bug.