Bug 1013502 - Chapter 13. JAX-WS Web Services - not related to quickstarts
Chapter 13. JAX-WS Web Services - not related to quickstarts
Status: CLOSED DEFERRED
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation, Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: TBD EAP 7
Assigned To: sgilda
Jan Blizňák
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 04:39 EDT by Petr Sakař
Modified: 2015-10-28 19:53 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14875, Development Guide-6.2-1 Build Date: 18-09-2013 13:54:44 Topic ID: 8420-502224 [Latest]
Last Closed: 2015-10-28 19:53:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sakař 2013-09-30 04:39:44 EDT
Describe the issue:
The guide should use for demonstration and documentation code from quickstarts so the user can easily test it himself

Following quickstarts are missing:
- example of basic web service implementation (should be used in chapter 13.3.2 Write and Deploy a JAX-WS Web Service Endpoint) 
- example of basic web service client of service from previous example (should be used in chapter 13.4.2. Develop a JAX-WS Client Application)
- example of web service using WS-Addressing (for chapter 13.5.1. Enable Web Services Addressing (WS-Addressing))
- example of web service client of service from previous example (for chapter 13.5.1. Enable Web Services Addressing (WS-Addressing))


Examples of WS clients should include the description how to run the client.
Comment 1 Petr Sakař 2013-09-30 05:19:00 EDT
lot of examples is in the jbossws testsuite. Solution would be to productize the TS (jbossws is already productized, but TS is excluded from build) and reference it in dev docs
Comment 3 Rebecca Searls 2014-08-02 12:10:47 EDT
It would be helpful to see in the guide what you view as a good example
of a component using for demonstration and documentation code from quickstarts.
Would you provide a pointer to 1 or more examples?
Comment 5 Rostislav Svoboda 2014-09-04 09:13:17 EDT
Hi Rebecca, not sure if we have such component and Quickstarts example.

It would be great to have Quickstarts Petr was describing in the description.
I know that JBossWS CXF testsuite contains examples, maybe for the beginning we could mention them in the documentation. Question is if it's possible to link project resources from product documentation.
Comment 7 Rebecca Searls 2014-11-27 09:57:42 EST
4 new WS quickstarts added.  Each provides a service and client which matches
a code fragment in the 6.x JBoss Development Application Platform Development Guide(s) WS section.

jaxws-ejb  (see 
  https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Development_Guide/Write_and_Deploy_a_JAX-WS_Web_Service_Endpoint.html,
  Example 14.12. Exposing an Endpoint in an EJB)

jaxws-pojo  (see 
  https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Development_Guide/Write_and_Deploy_a_JAX-WS_Web_Service_Endpoint.html,
  Example 14.10. Example POJO Endpoint)

jaxws-retail  (see 
  https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Development_Guide/Write_and_Deploy_a_JAX-WS_Web_Service_Endpoint.html,
  14.3.2. Write and Deploy a JAX-WS Web Service Endpoint)

jaxws-addressing  (see 
  https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Development_Guide/Write_and_Deploy_a_JAX-WS_Web_Service_Endpoint.html,
  14.5.1. Enable Web Services Addressing (WS-Addressing))


Pull request submitted:  https://github.com/jboss-developer/jboss-eap-quickstarts/pull/1151.
Comment 10 sgilda 2015-07-22 09:31:37 EDT
@David Michaels: These quickstarts were never merged into the release because we were waiting for necessary updates, therefore we can not update the EAP 6.4 documentation with these examples. We can consider adding this to EAP 7 docs if we add the quickstarts there.

@Rebecca Searls: What happened to these quickstarts? You issued this pull [1] but never made the requested updates. Do you want to resurrect these for JBoss EAP 7?

[1] https://github.com/jboss-developer/jboss-eap-quickstarts/pull/1151
Comment 11 sgilda 2015-07-22 16:38:54 EDT
Talked to Rebecca and she is updating the quickstarts and plans to submit them for EAP 7.
Comment 12 Rebecca Searls 2015-07-23 08:40:06 EDT
Submitted new pull request, https://github.com/jboss-developer/jboss-eap-quickstarts/pull/1443
was not able to push squashed changes back into initial pull request,
Comment 13 sgilda 2015-07-24 16:26:36 EDT
I issued a pull with fixes back to Rebecca: https://github.com/rsearls/jboss-eap-quickstarts/pull/1
Comment 14 Rebecca Searls 2015-07-27 07:24:56 EDT
I have accepted all your edits.  I integrated your pull request to my account.
Thanks for all those edits.
Comment 16 Rebecca Searls 2015-07-28 07:08:49 EDT
In JDK 8, wsconsume (org.jboss.ws.plugins:maven-jaxws-tools-plugin)
requires the presence of ${SOMEPATH}/jdk1.8.0_05/jre/lib/jaxp.properties,
contents javax.xml.accessExternalSchema = all
(see http://docs.oracle.com/javase/7/docs/api/javax/xml/XMLConstants.html#ACCESS_EXTERNAL_SCHEMA
 http://stackoverflow.com/questions/23011547/webservice-client-generation-error-with-jdk8) 

For quickstart jaxws-retail the user needs to be informed they require
this file.  How should I handle this?  Provide jaxp.properties in the
quickstart and document this in the README?
Comment 17 sgilda 2015-07-28 07:24:11 EDT
Yes. That works. Provide the file in the root directory of the quickstart and add  instructions to copy it to the correct location. Also add the link to http://docs.oracle.com/javase/7/docs/api/javax/xml/XMLConstants.html#ACCESS_EXTERNAL_SCHEMA,
Comment 18 anrobert 2015-10-28 19:53:02 EDT
Migrated to JIRA -> https://issues.jboss.org/browse/JBEAP-1692

Note You need to log in before you can comment on or make changes to this bug.