Bug 1013515 - [deploy] Failed to create app with multiple haproxy on fork_ami_deploy_873
[deploy] Failed to create app with multiple haproxy on fork_ami_deploy_873
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 05:13 EDT by Meng Bo
Modified: 2015-05-14 19:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:33:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-09-30 05:13:53 EDT
Description of problem:
Enable the multiplier for the haproxy cartridge, enable the ha for the application. Try to create scalable app and scale up the app to generate the multiple haproxy.
Will meet node execution failure.

Version-Release number of selected component (if applicable):
fork_ami_deploy_873

How reproducible:
always

Steps to Reproduce:
1.Launch fork_ami_deploy_873
2.Enable multiplier for haproxy cartridge
    Scaling:
      Min: 1
      Max: 2
      Multiplier: 2
 Restart ruby193-mcollective service
3.Enable application ha on the broker
#cat /etc/openshift/broker-dev.conf
ALLOW_HA_APPLICATIONS="true"
4.Allow ha for user
#oo-admin-ctl-user -l bmeng@redhat.com --allowha true
5.Restart broker and clear broker cache
6.Create scalable app and scale it up to generate multiple ha


Actual results:
Will meet node execution failure when scale up to the gear which should contain haproxy cartridge.

Expected results:
App with multiple haproxy should be created successfully.

Additional info:
develogment log:
2013-09-30 04:55:56.442 [DEBUG] DEBUG: rpc_client.custom_request('cartridge_do', {:cartridge=>"openshift-origin-node", :action=>"update-cluster", :args=>{"--with-app-uuid"=>"5249301247b3575830000001", "--with-app-name"=>"php1s", "--with-container-uuid"=>"5249301247b3575830000001", "--with-container-name"=>"php1s", "--with-namespace"=>"bmengdev", "--with-request-id"=>"27a42791e47ba7fc9761373b99ba400b", "--proxy-gears"=>"5249301247b3575830000001,php1s,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com 412516521613331680722944,412516521613331680722944,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com", "--web-gears"=>"5249301247b3575830000001,php1s,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com,38031 985065544290279058571264,985065544290279058571264,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com,38036 de885e8a29a611e3b89a22000aa5110d,de885e8a29a611e3b89a22000aa5110d,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com,38041 412516521613331680722944,412516521613331680722944,bmengdev,ec2-54-226-165-143.compute-1.amazonaws.com,38046", "--cart-name"=>"openshift-origin-node"}}, ip-10-165-17-13, {'identity' => ip-10-165-17-13}) (Request ID: 27a42791e47ba7fc9761373b99ba400b) (pid:5676)
2013-09-30 04:55:57.686 [DEBUG] DEBUG: [#<MCollective::RPC::Result:0x0000000179f0d0 @agent="openshift", @action="cartridge_do", @results={:sender=>"ip-10-165-17-13", :statuscode=>1, :statusmsg=>"cartridge_do_action failed 1. Output undefined local variable or method `entry' for #<OpenShift::Runtime::ApplicationContainer:0x00000003db8438>", :data=>{:time=>nil, :output=>"undefined local variable or method `entry' for #<OpenShift::Runtime::ApplicationContainer:0x00000003db8438>", :exitcode=>1, :addtl_params=>nil}}>] (Request ID: 27a42791e47ba7fc9761373b99ba400b) (pid:5676)
2013-09-30 04:55:57.688 [DEBUG] DEBUG: MCollective Response Time (execute_direct: update-cluster): 1.247479882s  (Request ID: 27a42791e47ba7fc9761373b99ba400b) (pid:5676)
Comment 1 Rajat Chopra 2013-10-08 23:46:38 EDT
Looks like the new update_cluster functionality -
"undefined local variable or method `entry' for #<OpenShift::Runtime::ApplicationContainer:0x00000003db8438>"
Comment 2 Meng Bo 2013-10-09 06:28:15 EDT
Checked the issue on latest devenv, cannot reproduce this on devenv_3874.
Comment 3 Mrunal Patel 2013-10-09 16:16:14 EDT
I wasn't able to reproduce this on master (where the build/deploy code is now).
Comment 4 Meng Bo 2013-10-10 00:31:14 EDT
It works on devenv_3880, move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.