Bug 1013547 - Add TUI information to log file.
Add TUI information to log file.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: AutomationBlocker, FutureFeature
Depends On: 991267
Blocks: 999348
  Show dependency treegraph
 
Reported: 2013-09-30 06:28 EDT by Fabian Deutsch
Modified: 2015-12-02 08:34 EST (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Enhancement
Doc Text:
Added a feature to show pages in the TUI 1. Press `F2` 2. [root@localhost admin]# cat /var/log/ovirt-node.log | grep 'Current page' 3. Output appears as follows: 2013-11-11 08:16:42,112 INFO Current page is 'Network' 2013-11-11 08:16:42,303 INFO Current page is 'Status' 2013-11-11 08:17:05,004 INFO Current page is 'Status' 2013-11-11 08:17:05,028 INFO Current page is 'Status' Also, pressing F12 will reset the cursor to the original position.
Story Points: ---
Clone Of: 991267
Environment:
Last Closed: 2014-01-21 14:52:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17959 None None None Never
oVirt gerrit 18927 None None None Never

  None (edit)
Description Fabian Deutsch 2013-09-30 06:28:53 EDT
+++ This bug was initially created as a clone of Bug #991267 +++

Description of problem:

1. In rhevh64 or lower version, when you switch the tabs in TUI(snack), the TUI will add the message like "Current Page is 1" into `ovirt.log`. This is very helpful for TUI related automation-case.
But this message can not be found in log files anymore in rhevh65.
So please add equivalent function in rhevh65

2. In rhevh64 or lower version, there is a built-in hot key `F12`. This hot key will reset the cursor to the  initial position. 
So please add equivalent hot-key in rhevh65

--- Additional comment from Ying Cui on 2013-08-12 08:17:25 CEST ---

 Priority: High
 Severity: High

--- Additional comment from Fabian Deutsch on 2013-08-12 12:18:15 CEST ---

Tested as follows:

1. Log into UI w/ patch
2. Enter Network page
3. Press F12
4. Status page was shown again

--- Additional comment from Fabian Deutsch on 2013-09-02 11:28:47 CEST ---

There is now also a log entry in the logfile saying:

"Current page is '…'" using the page name.

--- Additional comment from Fabian Deutsch on 2013-09-06 13:51:24 CEST ---

Hey Yaning,

I gave it another try.

Tested as follows:
1. Apply patch
2. Start UI in dev mode:
PYTHONPATH=src/ scripts/ovirt-node-setup --dry --defaults /tmp/cfg_dummy
3. $ grep "Current page" /tmp/ovirt-node.debug.log .../ovirt/gerrit/ovirt-node/src/ovirt/node/app.py:236:switch_to_plugin: Current page is 'Status'
Comment 2 Yaning Wang 2013-10-09 22:50:13 EDT
Hi Fabian

1. `F12` works as well as expected, thanks
2. But the "Current page is '…'" still can't find in log file
3. About `Apply patch`, is this patch need to manually apply and not included by default?
   
version info "rhev-hypervisor6-6.5-20130930.0.auto665.el6"
Comment 3 Fabian Deutsch 2013-10-10 07:12:26 EDT
Hey Yaning,

I will check this over the day and get back to this. There might be a patch missing.
Comment 4 Yaning Wang 2013-10-17 22:12:22 EDT
Test on RHEV-H 6.5 Snapshot 4 (untagged) (6.5-20131017.0)

Log function still not work.
Comment 5 Fabian Deutsch 2013-10-18 05:11:09 EDT
(In reply to Yaning Wang from comment #4)
> Test on RHEV-H 6.5 Snapshot 4 (untagged) (6.5-20131017.0)
> 
> Log function still not work.

Yes. I was aware if that. A workaround is to drop to shell and run the TUI in debug mode:
1. press f2 and drop to shell
2. run: ovirt-node-setup --debug

The hints will then appear in the /var/log/ovirt-node.debug.log

But tha is just a workaround and I target to include a fix ASAP.
Comment 6 Fabian Deutsch 2013-10-18 05:41:20 EDT
The final problem was an incorrect logging level (it was logged with the debug level, instead of info), this is now fixed here:
http://gerrit.ovirt.org/20285
Comment 14 Cheryn Tan 2013-11-07 19:33:46 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 15 Yaning Wang 2013-11-11 03:21:19 EST
Verified on the version:

rhevh-6.5-20131031.1.0

Steps:

1. Press `F2`
2. [root@localhost admin]# cat /var/log/ovirt-node.log | grep 'Current page'
3. get output as follow:

2013-11-11 08:11:24,162       INFO Current page is 'Welcome'
2013-11-11 08:11:26,445       INFO Current page is 'Keyboard'
2013-11-11 08:11:27,382       INFO Current page is 'Boot Device'
2013-11-11 08:11:28,433       INFO Current page is 'Data Device'
2013-11-11 08:11:30,669       INFO Current page is 'Storage Sizes'
2013-11-11 08:11:33,118       INFO Current page is 'Console Password'
2013-11-11 08:11:39,809       INFO Current page is 'Installation Progress'
2013-11-11 08:12:51,805       INFO Current page is 'Status'
2013-11-11 08:12:51,830       INFO Current page is 'Status'
2013-11-11 08:12:52,397       INFO Current page is 'Network'
2013-11-11 08:12:52,579       INFO Current page is 'Security'
2013-11-11 08:15:19,499       INFO Current page is 'Network'
2013-11-11 08:16:35,439       INFO Current page is 'Status'
2013-11-11 08:16:35,918       INFO Current page is 'Network'
2013-11-11 08:16:36,105       INFO Current page is 'Security'
2013-11-11 08:16:42,112       INFO Current page is 'Network'
2013-11-11 08:16:42,303       INFO Current page is 'Status'
2013-11-11 08:17:05,004       INFO Current page is 'Status'
2013-11-11 08:17:05,028       INFO Current page is 'Status'
Comment 17 errata-xmlrpc 2014-01-21 14:52:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.