Bug 101360 - (NET E100) e100 in installkernel does not handle 10Mb/half-duplex
(NET E100) e100 in installkernel does not handle 10Mb/half-duplex
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 02:44 EDT by Jan Iven
Modified: 2013-07-02 22:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 20:47:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The fix (1.83 KB, text/plain)
2003-09-15 16:57 EDT, Wen-Hwa Tao
no flags Details

  None (edit)
Description Jan Iven 2003-07-31 02:44:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
Trying to install "severn" on an old Highscreen workstation connected via Intel
combo card to a 10Mbit hub, no network traffic seems to happen (cannot find
installation server, cannot do reverse DNS, cannot get DHCP replies).

The "e100" module says on VT3 (copied by hand, may have typos):

e100 driver: Intel PRO/100 Network Driver - version 2.3.13-k1
divert: allocating divert_blk for eth0
e100: selftest OK,
e100: 503 serial component detected which cannot autonegotiate
e100: speed/duplex forced to 10Mbps/Half duplex

Whenever the loader is trying to access the network ("* waiting for link" on
VT2), I see

"eth0 NIC link is UP 100Mbps half duplex" on VT3,
so maybe the installer is getting things wrong. The port on the hub works fine
(link light is on, machine has network access when not trying to use "severn").

I have tried with acpi=off (no change), and have tried to load an alternative
driver (eepro100), but for some reason I cannot get manual driver selection to
work (tried booting with "linux expert" and "linux dd", select either e100 or
eepro100 driver, both will fail... means I cannot force 10Mbs/HD over driver
options either)

lspci -vv says
00:0e.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 02)
        Subsystem: Intel Corp. EtherExpress PRO/10+
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (2000ns min, 14000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at e9100000 (32-bit, prefetchable) [size=4K]
        Region 1: I/O ports at e400 [size=32]
        Region 2: Memory at e9000000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at e8000000 [disabled] [size=1M]

lspci -vvn
00:0e.0 Class 0200: 8086:1229 (rev 02)
        Subsystem: 8086:0003
 

Since this is a combo card (BNC/TP/AUI), I wonder whether e100 is the correct
driver at all.. was using the "eepro100" driver happily before.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot severn installation floppy or PXE image copied to hard disk
2. either choose DHCP or static IP
3. try NFS install
    

Actual Results:  no network-related things (DHCP, rDNS, NFS mount) work

Expected Results:  normal installation

Additional info:
Comment 1 Jan Iven 2003-08-07 05:13:24 EDT
eepro100 works (both in installkernel and after installation).

e100 with the 'normal' kernel does not work, says:

kernel: e100: 503 serial component detected which cannot autonegotiate
kernel: e100: speed/duplex forced to 10Mbps / Half duplex
kernel: e100: eth0: Intel(R) PRO/100 Network Connection
kernel: e100: eth0 NIC Link is Up 100 Mbps Half duplex

so it is forcing the card into 100Mbs mode as well despite the previous warning.
Comment 2 Wen-Hwa Tao 2003-09-15 16:57:09 EDT
Created attachment 94511 [details]
The fix

This adapter is 82557-based with 82503 PHY. 82503 is non-MII PHY, and supports
only 10 Half. The patch was against 3.0 B2.

Note You need to log in before you can comment on or make changes to this bug.