Bug 1013629 - All help page links should now point to help/reference/ or help/getting-started/ pages
All help page links should now point to help/reference/ or help/getting-start...
Status: CLOSED DUPLICATE of bug 1024118
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: sat570-blockers
  Show dependency treegraph
 
Reported: 2013-09-30 09:22 EDT by Jiří Mikulka
Modified: 2014-10-16 10:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-16 10:51:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiří Mikulka 2013-09-30 09:22:36 EDT
Description of problem:
As part of bug 1012660 fixing most of the links to help pages were changed from the old help/channel-mgmt to the new help/reference or help/getting-started pages, but there are still few needed to be changed (in Perl pages), namely:

web/html/network/errata/manage/errata_channel_intersection.pxt
  <h1>Erratum: <rhn-errata-advisory /> <rhn-help guide="channel-mgmt" href="channel-mgmt-Custom_Errata_Management.jsp" /></h1>
web/include/network/software/channels/manage/manage_channels_header.pxi
  <rhn-toolbar base="h1" img="/img/rhn-icon-channels.gif" help-url="channel-mgmt-Custom_Channel_and_Package_Management-Managed_Software_Channel_Details.jsp" help-guide="channel-mgmt" deletion-type="software channel" deletion-url="/rhn/channels/manage/Delete.do?cid={channel_id}" deletion-acl="user_role(channel_admin); formvar_exists(cid)">

Also search-server points incorrectly to the old channel-mgmt help pages:

search-server/spacewalk-search/nutch/crawl_jsp/conf/crawl-urlfilter.txt
  +.*/docs/guides/channel-mgmt/en/
search-server/spacewalk-search/nutch/crawl_jsp/urls/urls.txt
  file:///shared/repo/trunk/eng/docs/guides/channel-mgmt/en/

Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130927.0

How reproducible:
always

Steps to Reproduce:
1. check the code of the above mentioned files

Actual results:
old channel-mgmt help page is referenced

Expected results:
new reference or getting-started help page should be referenced
Comment 1 Stephen Herr 2013-09-30 14:45:20 EDT
Committed to Spacewalk master:
2a1a906671fdda5aa3566fd77686f7a1742a7e9b
Comment 3 Lukáš Hellebrandt 2014-10-16 09:03:52 EDT
The help icons now correctly link to the Getting Started Guide, however, the page linked is sometimes totally unrelated to the action performed. This is caused by including the same .pxi file in different contexts.

For example, the help icon on 'Channels -> Manage -> Clone' links correctly to the Getting Started Guide, but the page linked (1.2.10. Removing Software Packages) is totally unrelated; it should probably link to 1.2.8. Cloning Software Channels. The link comes from the "web/include/network/software/channels/manage/manage_channels_header.pxi" file which is used in multiple pages handling different actions. See 'grep -R manage_channels_header.pxi'.
Comment 4 Tomas Lestach 2014-10-16 10:51:10 EDT
As it was decided to remove the help pages and their references, we're not going to update the links or the help pages.
Closing as duplicate of Bug 1024118, where Grant removes the help pages and their references.

*** This bug has been marked as a duplicate of bug 1024118 ***

Note You need to log in before you can comment on or make changes to this bug.