Bug 1013645 - Deployment performance regression in EAP 6.2.0.ER3
Deployment performance regression in EAP 6.2.0.ER3
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER10
: EAP 6.3.0
Assigned To: Rémy Maucherat
Jan Martiska
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 09:57 EDT by Jan Martiska
Modified: 2014-08-05 07:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-04 07:19:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Martiska 2013-09-30 09:57:29 EDT
I noticed a visible performance regression during deployment of applications, namely web applications, it seems.
I packed a simple reproducer EAR application consisting of multiple simple web archives. On the testing machine, 
on 6.2.0.ER2: deployment time is around 6300 ms
on 6.2.0.ER3: deployment time is around 7600 ms
This is a regression by 20%.

By time needed to deploy, I mean the difference between timestamps of these two logs:
09:26:40,885 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-7) JBAS015876: Starting deployment of "webapps.ear" (runtime-name: "webapps.ear")
09:26:47,184 INFO  [org.jboss.as.server] (management-handler-thread - 1) JBAS018559: Deployed "webapps.ear" (runtime-name : "webapps.ear")

When I deployed other types of applications (webservices, ejb jars,.. even if packed in EAR, too) I did not notice any regression.
Comment 2 Jan Martiska 2013-10-08 06:08:14 EDT
Still the same in ER4 and ER5.
Comment 3 Rémy Maucherat 2013-10-21 08:39:43 EDT
This could be caused by a change to unpack the archives in WarStructureDeploymentProcessor (o.jb.as.web.deployment) or in the EAR processor itself. If this can be confirmed (I didn't do it), since this fixed issues, this regression should be considered normal (expanding more has a cost).

Other than that, I'm not aware of significant deployment changes.
Comment 4 John Doyle 2013-10-28 15:32:44 EDT
Is there a regression from 6.1.1 for this test?
Comment 6 Jan Martiska 2013-10-29 03:39:26 EDT
Yes, this is a regression compared to 6.1.1.
Comment 7 Martin Velas 2014-08-04 07:19:46 EDT
The regression of the deployment performance for EAP 6.3.0.ER10 against the 6.1.1 is not so significant:

6.1.1.GA   - 6.65sec
6.3.0.ER10 - 6.96sec (in average for attached webapps.ear)

Due to Comment 3 and discussion with Jan closed as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.