Bug 1013689 - UI should raise success notification for all of the activities under products page
UI should raise success notification for all of the activities under products...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Walden Raines
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 11:31 EDT by Kedar Bidarkar
Modified: 2016-04-22 12:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-11 08:23:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6653 None None None 2016-04-22 12:47 EDT

  None (edit)
Description Kedar Bidarkar 2013-09-30 11:31:15 EDT
Description of problem:
UI should raise success notification for all of the activities under products page.

Version-Release number of selected component (if applicable):
UI should raise success notification for all of the activities under products page

How reproducible:
UI notification are required for automation.

Steps to Reproduce:
1.Perform any activity on the products page to find no notifications
2.
3.

Actual results:
No notifications observed

Expected results:
Notification are required

Additional info:
Comment 2 Brad Buckingham 2014-07-16 15:03:35 EDT
Observed no notification in the UI in scenarios such as the following:
1. create product
2. create repository
3. updated a field in the repository (e.g. name)
4. repository sync (from the repo)

Observed notification in the UI in scenarios such as the following: 
5. updated a field in the product (e.g. name)
6. deleted repository
7. deleted product
8. repository sync (from repos list)

For consistency with other pages, we should probably include a notice on 2 & 3.  For 1, we don't generally include notification when the base object is created.
For 4, we don't generally create a notification when a dynflow task pane is opened, showing the status of the action that was initiated.
Comment 3 Walden Raines 2014-07-16 16:26:21 EDT
Created redmine issue http://projects.theforeman.org/issues/6653 from this bug
Comment 4 Walden Raines 2014-07-16 16:44:22 EDT
PR: https://github.com/Katello/katello/pull/4445
Comment 5 Bryan Kearney 2014-07-17 12:01:19 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6653 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|8a06d99a5c4a4cb30ff0d952b23f7f124c5c8e0c.
Comment 7 sthirugn@redhat.com 2014-07-25 15:49:05 EDT
Verified as per Comment 2:

1. create product - NO
2. create repository - YES
3. updated a field in the repository (e.g. name) - YES
4. repository sync (from the repo) -  NO
5. updated a field in the product (e.g. name) - YES
6. deleted repository - YES
7. deleted product - YES
8. repository sync (from repos list) - YES

Version Tested:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.29-1.el6sat.noarch
* foreman-compute-1.6.0.29-1.el6sat.noarch
* foreman-gce-1.6.0.29-1.el6sat.noarch
* foreman-libvirt-1.6.0.29-1.el6sat.noarch
* foreman-ovirt-1.6.0.29-1.el6sat.noarch
* foreman-postgresql-1.6.0.29-1.el6sat.noarch
* foreman-proxy-1.6.0.21-1.el6sat.noarch
* foreman-selinux-1.6.0-8.el6sat.noarch
* foreman-vmware-1.6.0.29-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
Comment 9 Bryan Kearney 2014-09-11 08:23:27 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.