Bug 101369 - Squirrelmail install should add apache to trusted_users
Squirrelmail install should add apache to trusted_users
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: squirrelmail (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 08:34 EDT by Daniel Senie
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-08 06:12:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2003-07-31 08:34:30 EDT
Description of problem:

Users sending email via Squirrelmail trigger complaints that sendmail is 
sending with -f, without a user being listed in /etc/mail/trusted-users.

Example from sendmail's logging output (with identifying info altered):

Jul 30 14:16:16 hostname sendmail[31415]: xxxxxxxxxxx: Authentication-Warning:
 XXXXX.example.com: apache set sender to user@example.net using -f

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:

adding apache into trusted-users removes the issue. Would recommend this 
approach, but it should be documented as there could be implications if there 
are virtual hosting setups on the same server.


Additional info:
Comment 1 Gary Benson 2004-01-08 06:12:25 EST
This is something that individual mail admins should address because,
as you say, SquirrelMail might not be the only program on the server
that is sending mail.

Note You need to log in before you can comment on or make changes to this bug.