Bug 1013733 - [abrt] yum-3.4.3-106.fc19: grabber.py:2387:estimate:OverflowError: (34, 'Numerical result out of range')
[abrt] yum-3.4.3-106.fc19: grabber.py:2387:estimate:OverflowError: (34, 'Nume...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:630a55f38b05d4bed14a38ccc19...
: Reopened
: 1036726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 12:45 EDT by Martin Bříza
Modified: 2014-06-04 03:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-urlgrabber-3.10.1-0.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 00:58:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (3.20 KB, text/plain)
2013-09-30 12:45 EDT, Martin Bříza
no flags Details
File: environ (2.43 KB, text/plain)
2013-09-30 12:45 EDT, Martin Bříza
no flags Details
timedhosts (776 bytes, text/plain)
2013-10-01 08:25 EDT, Martin Bříza
no flags Details

  None (edit)
Description Martin Bříza 2013-09-30 12:45:16 EDT
Description of problem:
Tried to 'yum update'

Version-Release number of selected component:
yum-3.4.3-106.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /bin/yum update
dso_list:       python-urlgrabber-3.9.1-27.fc19.noarch
executable:     /bin/yum
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
grabber.py:2387:estimate:OverflowError: (34, 'Numerical result out of range')

Traceback (most recent call last):
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 126, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 532, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 494, in doCommand
    ret = base.updatePkgs(extcmds, update_to=(basecmd == 'update-to'))
  File "/usr/share/yum-cli/cli.py", line 974, in updatePkgs
    self.update()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 4957, in update
    updates = self.up.getUpdatesTuples()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1069, in <lambda>
    up = property(fget=lambda self: self._getUpdates(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 830, in _getUpdates
    self._up = rpmUtils.updates.Updates(self.rpmdb.simplePkgList(), self.pkgSack.simplePkgList())
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1050, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 770, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 344, in populateSack
    self.doSetup()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 157, in doSetup
    self.retrieveAllMD()
  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 88, in retrieveAllMD
    dl = repo._async and repo._commonLoadRepoXML(repo)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1452, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1230, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1012, in _getFile
    result = self.grab.urlgrab(misc.to_utf8(relative), local,
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 693, in <lambda>
    grab = property(lambda self: self._getgrab())
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 688, in _getgrab
    self._setupGrab()
  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 654, in _setupGrab
    failure_callback=mirror_failure)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 274, in __init__
    self.mirrors.sort(key=estimate, reverse=True)
  File "/usr/lib/python2.7/site-packages/urlgrabber/mirror.py", line 268, in estimate
    speed, fail = _TH.estimate(m['mirror'])
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2387, in estimate
    k = 2**((ts - time.time()) / default_grabber.opts.half_life)
OverflowError: (34, 'Numerical result out of range')

Local variables in innermost frame:
ts: 4294967302
default_speed: 1000000.0
baseurl: 'http://mirror.us.leaseweb.net/rpmfusion/free/fedora/releases/19/Everything/x86_64/debug/'
host: 'mirror.us.leaseweb.net'
fail: 0
speed: 6908344
Comment 1 Martin Bříza 2013-09-30 12:45:22 EDT
Created attachment 805378 [details]
File: backtrace
Comment 2 Martin Bříza 2013-09-30 12:45:25 EDT
Created attachment 805379 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-10-01 03:23:51 EDT
Please, could you attach your /var/cache/yum//x86_64/19/timedhosts?  
I've already seen (and thought I've fixed as well) this bug reported, but never reproduced it myself.. See BZ 894630
Comment 4 Zdeněk Pavlas 2013-10-01 04:28:21 EDT
What version of urlgrabber are you using?  Was it pre 3.9.1-25.fc19?
Comment 5 Fedora Update System 2013-10-01 07:54:50 EDT
createrepo-0.9.9-23.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/createrepo-0.9.9-23.fc19
Comment 6 Martin Bříza 2013-10-01 08:25:32 EDT
Created attachment 805896 [details]
timedhosts
Comment 7 Zdeněk Pavlas 2013-10-01 08:28:14 EDT
Sorry, wrong BZ# entered to bodhi..  This bug was reported with ancient (pre 
Mar 7 2013) python-urlgrabber installed.  Closing.
Comment 8 Martin Bříza 2013-10-01 08:30:33 EDT
Alright, so what should I do to update my system, please?
Comment 9 Zdeněk Pavlas 2013-10-01 08:41:01 EDT
Enable the fedora-updates repo, and run "yum update" as root.
Comment 10 Zdeněk Pavlas 2013-10-01 09:31:23 EDT
Found out that the fix shipped in -25 was incomplete.  Fixed in HEAD. 
Thanks for the report!

http://yum.baseurl.org/gitweb?p=urlgrabber.git;a=commitdiff;h=f2a33c7c2f
Comment 11 Fedora Update System 2013-10-17 07:02:12 EDT
python-urlgrabber-3.10-0.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.10-0.fc19
Comment 12 Fedora Update System 2013-10-18 15:59:27 EDT
Package python-urlgrabber-3.10-0.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-urlgrabber-3.10-0.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19353/python-urlgrabber-3.10-0.fc19
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-10-22 00:58:38 EDT
python-urlgrabber-3.10-0.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Zdeněk Pavlas 2013-12-02 10:18:05 EST
*** Bug 1036726 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2014-05-30 05:28:50 EDT
python-urlgrabber-3.10.1-0.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.10.1-0.fc20
Comment 16 Fedora Update System 2014-06-04 03:54:11 EDT
python-urlgrabber-3.10.1-0.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.