Bug 1013734 - OSError: [Errno 5] Input/output error
OSError: [Errno 5] Input/output error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:61bf81c4ba1f2936ee337ae938d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 12:45 EDT by mnobile
Modified: 2013-09-30 12:59 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 12:59:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (653.99 KB, text/plain)
2013-09-30 12:45 EDT, mnobile
no flags Details
File: anaconda.log (11.30 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: environ (440 bytes, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: lsblk_output (2.36 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: messages (368.41 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: nmcli_dev_list (3.36 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: os_info (179 bytes, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: program.log (39.68 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: storage.log (187.45 KB, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: ifcfg.log (573 bytes, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details
File: packaging.log (201 bytes, text/plain)
2013-09-30 12:46 EDT, mnobile
no flags Details

  None (edit)
Description mnobile 2013-09-30 12:45:51 EDT
Description of problem:
installing fedora 19

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/subprocess.py", line 1308, in _execute_child
    raise child_exception
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 80, in _run_program
    preexec_fn=chroot, cwd=root, env=env)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iutil.py", line 116, in execWithRedirect
    return _run_program(argv, stdin=stdin, stdout=stdout, root=root, env_prune=env_prune)[0]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 577, in _recreateInitrds
    root=ROOT_PATH)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 148, in postInstall
    self._recreateInitrds()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    payload.postInstall()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 5] Input/output error

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Desktop-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19
Comment 1 mnobile 2013-09-30 12:45:57 EDT
Created attachment 805380 [details]
File: anaconda-tb
Comment 2 mnobile 2013-09-30 12:46:02 EDT
Created attachment 805381 [details]
File: anaconda.log
Comment 3 mnobile 2013-09-30 12:46:06 EDT
Created attachment 805382 [details]
File: environ
Comment 4 mnobile 2013-09-30 12:46:10 EDT
Created attachment 805383 [details]
File: lsblk_output
Comment 5 mnobile 2013-09-30 12:46:15 EDT
Created attachment 805384 [details]
File: messages
Comment 6 mnobile 2013-09-30 12:46:18 EDT
Created attachment 805385 [details]
File: nmcli_dev_list
Comment 7 mnobile 2013-09-30 12:46:26 EDT
Created attachment 805386 [details]
File: os_info
Comment 8 mnobile 2013-09-30 12:46:30 EDT
Created attachment 805387 [details]
File: program.log
Comment 9 mnobile 2013-09-30 12:46:34 EDT
Created attachment 805388 [details]
File: storage.log
Comment 10 mnobile 2013-09-30 12:46:40 EDT
Created attachment 805389 [details]
File: ifcfg.log
Comment 11 mnobile 2013-09-30 12:46:44 EDT
Created attachment 805390 [details]
File: packaging.log
Comment 12 David Shea 2013-09-30 12:59:20 EDT
There are a lot of errors in the messages file along the lines of this:

Sep 30 12:29:22 localhost kernel: [  264.381040] ata2: exception Emask 0x10 SAct 0x0 SErr 0x90202 action 0xe frozen
Sep 30 12:29:22 localhost kernel: [  264.381057] ata2: irq_stat 0x00400000, PHY RDY changed
Sep 30 12:29:22 localhost kernel: [  264.381065] ata2: SError: { RecovComm Persist PHYRdyChg 10B8B }
Sep 30 12:29:22 localhost kernel: [  264.381079] ata2: hard resetting link
Sep 30 12:29:24 localhost kernel: [  267.263032] ata2: softreset failed (device not ready)
Sep 30 12:29:24 localhost kernel: [  267.263041] ata2: applying PMP SRST workaround and retrying
Sep 30 12:29:25 localhost kernel: [  267.418052] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
Sep 30 12:29:25 localhost kernel: [  267.511784] ata2.00: configured for UDMA/133
Sep 30 12:29:25 localhost kernel: [  267.511799] ata2: EH complete
Sep 30 12:29:42 localhost kernel: [  284.849053] ata2: limiting SATA link speed to 1.5 Gbps

Sep 30 12:30:03 localhost kernel: [  305.924861] ata2: SError: { Persist HostInt PHYRdyChg 10B8B }
Sep 30 12:30:03 localhost kernel: [  305.924872] ata2.00: failed command: WRITE FPDMA QUEUED
Sep 30 12:30:03 localhost kernel: [  305.924887] ata2.00: cmd 61/00:00:38:ed:d6/04:00:00:00:00/40 tag 0 ncq 524288 out
Sep 30 12:30:03 localhost kernel: [  305.924887]          res 40/00:a0:e0:49:d7/00:00:00:00:00/40 Emask 0x50 (ATA bus error)
Sep 30 12:30:03 localhost kernel: [  305.924894] ata2.00: status: { DRDY }


It looks like your hard drive is failing.

Note You need to log in before you can comment on or make changes to this bug.