Bug 1013755 - katello-disconnected: export fails
katello-disconnected: export fails
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 13:33 EDT by Corey Welton
Modified: 2014-04-24 13:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-09-30 13:33:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):
katello-utils-1.4.3-3.el6sat.noarch


How reproducible:


Steps to Reproduce:
1.  Configure katello-disconnected and import a repo. 
2.  Attempt to export repo (export -t /var/tmp/export)
3.  View results

Actual results:
[root@tigger ~]# katello-disconnected export -t /var/tmp/export
/usr/share/katello-disconnected/lib/disconnected_pulp.rb:202:in `export': undefined method `retrieve_all' for #<Runcible::Wrapper:0x000000031e0ac0> (NoMethodError)
	from /usr/bin/katello-disconnected:429:in `<main>'

Expected results:
Able to export.

Additional info:
Comment 2 Mike McCune 2013-10-22 21:36:41 EDT
Couldn't reproduce this, sending back to Corey to re-test
Comment 3 Corey Welton 2013-10-22 23:38:26 EDT
Yep, this was fixed at some point, probably an updated version of runcible or something.

QA Verified.
Comment 4 Corey Welton 2013-10-23 11:56:08 EDT
We're actually gonna co-opt this one for a different export failure reason.

When user tries to export a synced archive it provides some suggestion that there's been a successful export, but the export size is terribly incorrect.

Watching finished
Done watching ...
 Copying content to /var/tmp/export
rsync: link_stat "/var/www/pulp_puppet/http/repos" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1039) [sender=3.0.6]
 Archiving contents of /var/tmp/export into 4600M tar archives.
 NOTE: This may take a while.
tar: Removing leading `/' from member names

Done exporting content, please copy /var/tmp/export/* to your disconnected host

[root@ibm-x3250m4-05 ~]# cd /var/tmp/export
[root@ibm-x3250m4-05 export]# ls -alF
total 16
drwxr-xr-x. 2 apache apache 4096 Oct 23 11:43 ./
drwxrwxrwt. 3 root   root   4096 Oct 23 11:43 ../
-rw-r--r--. 1 root   root    479 Oct 23 11:43 content-export-00
-rwxr-xr-x. 1 root   root     88 Oct 23 11:43 expand_export.sh*
Comment 5 Mike McCune 2013-10-23 12:46:22 EDT
https://github.com/Katello/katello-misc/pull/21
Comment 8 Mike McCune 2013-10-23 18:36:41 EDT
This failed QA, export was stuck in the Packages/Packages/Packages loop.
Comment 9 Mike McCune 2013-10-25 13:08:49 EDT
https://github.com/Katello/katello-misc/pull/23
Comment 12 Corey Welton 2013-10-28 11:50:36 EDT
QA Verified!  Sync export completes and can be reimported into disconnected host.


Satellite-6.0.2-RHEL-6-20131025.0
Comment 15 Bryan Kearney 2014-04-24 13:10:54 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 16 Bryan Kearney 2014-04-24 13:11:58 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.