This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1013756 - Error message about window size
Error message about window size
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Azores
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 13:34 EDT by Frank Büttner
Modified: 2014-01-07 18:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 10:45:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2013-09-30 13:34:27 EDT
Description of problem:
When run an java webstart application an error entry in /var/log/messages will occur. 

Version-Release number of selected component (if applicable):


How reproducible:
every time


Steps to Reproduce:
1. visit the page http://www.skat-online.com/spielen.html with firefox
2. wait until the webstart appilcation loads.
3. take a look at /var/log/messaages

Actual results:

The error message:

gnome-session[1635]: Fensterverwalter-Warnung:Ungültiges WM_TRANSIENT_FOR-Fenster 0x220005c festgelegt für 0x2200061 (win0).
Sep 30 19:28:41 bart gnome-session[1635]: Fensterverwalter-Warnung:Fenster 0x2200061 (win0) zeigt durch einen MWM-Hinweis an, dass die Größe nicht veränderbar ist, setzt jedoch die minimale Größe auf 1 x 1 und die maximale Größe auf 2147483647 x 2147483647; dies ergibt keinen Sinn.



Expected results:
No error messages
Comment 1 Frank Büttner 2013-09-30 13:36:24 EDT
Package version: icedtea-web-1.4.1-0.fc19.x86_64
Comment 2 Andrew Azores 2013-10-17 14:33:18 EDT
The same message, in English:

gnome-session[1266]: Window manager warning: Window 0x34001cd (win0) sets an MWM hint indicating it isn't resizable, but sets min size 1 x 1 and max size 2147483647 x 2147483647; this doesn't make much sense.

This is just a window manager warning, not an error. Is there any incorrect/unexpected behaviour associated with this, other than the message being printed to /var/log/messages? Doing a quick search online for this warning shows it occurring for other applications as well, not just IcedTea-Web (Java WebStart), so I'm not sure that there's anything in particular to be fixed here.

Especially notable is that the min size is set to 1x1, which makes sense as a default minimum window size, and the max is set to MAX_INTxMAX_INT, MAX_INT being just 2^32 - 1. Which, to me, seems like a reasonable window maximum size for the window to set given no other context information. So some window being opened in the process of launching a WebStart application is unnecessarily specifying min/max sizes which are never needed since it's marked non-resizable.

I can take a look and see if we are mistakenly explicitly setting those values somewhere, but it seems to me like it could also be the applet itself from that webpage. And in either case it seems to be harmless, other than causing extra /var/log/messages output.
Comment 3 Asif Ali Rizvan 2014-01-07 05:23:10 EST
are you using metacity window manager (part of gnome)? cause it causes this bug for many wine programs, the wine program simply go crazy on going fullscreen!

Example: epsxe:

Window manager warning: Window 0x3c00007 (ePSXe - En) sets an MWM hint indicating it isn't resizable, but sets min size 1 x 1 and max size 2147483647 x 2147483647; this doesn't make much sense.


But openbox, xfwm4, kwin does fullscreen properly.
Comment 4 Frank Büttner 2014-01-07 12:58:25 EST
No I using the normal gnome 3.
Comment 5 Asif Ali Rizvan 2014-01-07 18:29:43 EST
(In reply to Frank Büttner from comment #4)
> No I using the normal gnome 3.

Yeah, gnome 3 also uses metacity; could you please run the software in "razorqt" with openbox or xfce4 desktop. I believe it is related to metacity i.e., gnome3's window manager.

Note You need to log in before you can comment on or make changes to this bug.