Bug 101379 - LTC3729-[BETA] RHEL3 does not support reiser as installed
LTC3729-[BETA] RHEL3 does not support reiser as installed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: dff
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-31 11:02 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 11:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-07-31 11:02:41 EDT
The following has be reported by IBM LTC:  
[BETA] RHEL3 does not support reiser as installed
Please fill in each of the sections below.

Hardware Environment:

2064-116, shark e20

Software Environment:

taroon under VM

Steps to Reproduce:
1. mount a pre-existing reiserfs volume
2.
3.

Actual Results:

message:

mount: fs type reiserfs not supported by kernel

Expected Results:

able to mount pre-existing volumes that have been formatted as reiserfs

Additional Information:

We have been using SuSE's 2.4.7 and 2.4.19 for quite some time so we have
hundreds of volumes formatted in the reiserfs. The last Redhat s/390 release
(7.1/7.2) is ancient history and within our lab, few users have tried it. All
our systems currently are SuSE. They will not be the least bit happy if they
have to convert their data volumes to ext3 because that is what RedHat has
choosen to package. RedHat is behind the curve in a big way here!

Reiserfs should be included in the kernel so that existing data volumes can be
mounted without having to recompile the kernel. The users should have an easy
option to use whatever file system they choose.by the by, jfs also is not
included in the installed base.

RedHat does not give the user a choice, but forces them into ext3.
- Red Hat needs to include JFS and Reiserfs in RHEL3.
Comment 1 Rik van Riel 2003-07-31 11:45:25 EDT
reiserfs and jfs are included, as modules in the kernel-unsupported RPM
Comment 2 Rik van Riel 2003-07-31 11:57:37 EDT
Note to the installer people: this scenario illustrates that we will need to
think of a way to get the -unsupported RPM installed when people really need it...
Comment 3 dff 2003-07-31 12:02:59 EDT
kernel-unsupported is available via the Red Hat Networks updates channel now.

packaging of kernel-unsupported will be improved in B2.
Comment 4 IBM Bug Proxy 2003-08-20 15:28:11 EDT
------ Additional Comments From jlsibley@us.ibm.com  2003-20-08 14:31 -------
I will test as soon as I get the Beta2 code. 
Comment 5 IBM Bug Proxy 2003-09-24 14:04:34 EDT
------ Additional Comments From jlsibley@us.ibm.com  2003-24-09 12:48 -------
This has only been partially fixed on beta2 CD. User must manually install
"kernel-unsupported" rpm to get mount support. There does not seem to be a
screen that allows you to select this option.

Tools to support reiser are not supplied, so there is no ability to fix or tune
and existing reiser fs from RHEL3. fsck, mkrs, tune, etc, are not supplied.

I think the IBM requirements for Reiser should be updated to include full
support for the filesystem, not just mount ability.

I think, if you look into it, the same will be true for JFS. The JFS mount
support was supplied by the "kernel unsupported" rpm, but I do think that the
tools have been added.

Any customer with SuSE currently installed may have trouble supporting existing
reiser filesystems on dasd when Redhat is installed. 
Comment 6 Matt Wilson 2003-09-24 14:10:56 EDT
this issue needs to be worked on a business level.
Comment 7 IBM Bug Proxy 2005-03-27 12:48:02 EST
---- Additional Comments From khoa@us.ibm.com  2005-03-27 12:45 EST -------
James - can we close this bug report now ?  Is this still an issue ?
(I am trying to clean up old bug reports....). 
Comment 8 IBM Bug Proxy 2005-03-28 13:04:01 EST
---- Additional Comments From jlsibley@us.ibm.com  2005-03-28 13:00 EST -------
This is part of an ongoing discussion, as I understand it with RedHat about 
Reiserfs. At what release do they provide full utility support for residerfs? 
Comment 9 mark wisner 2005-05-13 16:17:00 EDT
created issue tracker 72819

Note You need to log in before you can comment on or make changes to this bug.