Bug 1013794 - Sugar package should have the sugar-cp-all package as a dependecy, otherwise the control panel doesn't launch
Sugar package should have the sugar-cp-all package as a dependecy, otherwise ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sugar (Show other bugs)
19
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Simon Schampijer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 15:23 EDT by Eduardo Silva
Modified: 2013-11-05 08:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 08:56:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eduardo Silva 2013-09-30 15:23:15 EDT
Description of problem:
After an initial installation of the sugar package, the control panel didn't launch. I later found out this was because the 'sugar-cp-*' packages hadn't been installed alongside 'sugar'.

Version-Release number of selected component (if applicable):
0.98.8

How reproducible:
Allways

Steps to Reproduce:
1.Install sugar package
2.Launch sugar-emulator
3.Open "my settings"

Actual results:
Control panel fails to launch

Expected results:
Control panel should appear

I would also install a few of the other sugar-packages with 'sugar' such as sugar-browse for example.
Comment 1 Peter Robinson 2013-10-09 09:54:48 EDT
Actually it's a bug that it doesn't launch, there is no need to have any of the Control Panels installed (except for the two that are part of the core sugar package) and some deployments don't ship with a number of the panels which is why we split them out. 

That being said the proper way to install sugar is to do "yum install @sugar-desktop" which installs all things and the default supported activity set
Comment 2 Peter Robinson 2013-11-05 08:56:28 EST
sugar should be installed by group "yum install @sugar-desktop" not as a single package.

Note You need to log in before you can comment on or make changes to this bug.