Bug 1013814 - regression: radeon dpm disabled by default causes high gpu temperature and fan spin-up
regression: radeon dpm disabled by default causes high gpu temperature and fa...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 16:27 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2013-10-09 10:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.11.3-301.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-05 21:28:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2013-09-30 16:27:50 EDT
Description of problem:
Starting with kernel 3.11, the radeon driver gained better power management support for many chips, including "Southern Islands" GPUs, like my Radeon HD 7950 (TAHITI). However, it's disabled by default and causes GPU temperature to reach much higher levels compared to previous kernels (52°C vs. 39°C before). This also causes the GPU fans to kick in in regular intervals, making an irritating noise on what was a quite silent desktop before.

Version-Release number of selected component (if applicable):
kernel-3.11.1-200.fc19.x86_64 (radeon 2.34.0)

How reproducible:
Always

Steps to Reproduce:
1. boot 3.11.x kernel without radeon.dpm=1 parameter
2. check GPU temperature and listen to the fan noise

Actual results:
GPU reaches 50+ degrees Celsius and fans spin up at regular intervals to cool it.

Expected results:
GPU should keep a temperature below 40°C and be quiet when idle just like it did on 3.10.x kernels.

Additional info:
$ lspci -n
01:00.0 0300: 1002:679a
$ lspci
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950]

on kernel 3.10.11-200.fc19:
Sep 29 22:43:28 amaterasu kernel: [    1.851693] [drm] Initialized radeon 2.33.0 20080528 for 0000:01:00.0 on minor 0

on kernel 3.11.1-200.fc19:
Sep 29 23:26:30 amaterasu kernel: [    1.899323] [drm] Initialized radeon 2.34.0 20080528 for 0000:01:00.0 on minor 0

NOTE: booting with radeon.dpm=1 brings the temperature back below 40°C and the fans stay silent when GPU is idle.
Comment 1 Alex Deucher 2013-10-01 17:37:52 EDT
We switched to using the default clocks for SI in 3.11 to match the behavior of older asics.  It has since been disabled.

http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=360991867d83e10827d907ef67206986a98953b3
Comment 2 Josh Boyer 2013-10-02 08:18:43 EDT
I don't see that commit queued for 3.11.4 yet, but hopefully soon.
Comment 3 Fedora Update System 2013-10-03 09:43:12 EDT
kernel-3.11.3-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.3-201.fc19
Comment 4 Fedora Update System 2013-10-03 09:45:00 EDT
kernel-3.11.3-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.3-301.fc20
Comment 5 Fedora Update System 2013-10-03 22:02:14 EDT
Package kernel-3.11.3-301.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.3-301.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18268/kernel-3.11.3-301.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-10-05 21:28:51 EDT
kernel-3.11.3-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-10-09 10:14:09 EDT
kernel-3.11.3-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.